After update to DSM Version: 7.1-42661 Update 2 - QUIC UDP connectivity issue from Docker

Hello community,

I have properly configured my STORJ nodes (on Windows and under Docker on SYNOLOGY NAS).

SYNOLOGY versions:
|Functionality|Docker-based Packages|
|Product|DS1817+|
|Version|DSM 7.1-42661 Update 2|

DOCKER version: 20.10.3-1306

I have updated SYNOLOGY DSM system. Everything went fine, docker operates properly and nodes under docker as well. Node on Virtual Machine (WINDOWS10) works properly.

Only issue which I have is QUIC looks uncofigured (printscreen). I tried re-add one node but still is the same.

I did not change anything on router and this works properly for all nodes from this NAS.

[Steps to Reproduce]
I have tried reinstall Docker. Remove and re-add all docker containers. Remove and re-add port forward rules on router.

But I did not change anything. I have only updated DSM to latest version.

Did you changed anything how to docker/NAS manage UDP and QUIC functionality? QUIC - Wikipedia

I have tried contact STORJ forum:

Also tried SYNOLOGY forum (cannot add link as new user on forum).

Unfortunatelly nobody helped me until now. I have also bought new router so we can remove point of failure router and port forwarding. This works without issue for my nodes running on Windows machines behind same router on the same network.
This is only for SYNOLOGY and Docker after lates DSM update.

Maybe needs to be something to check on docker side which is used in app on SYNOLOGY DSM.

Thank you

Wigo

image

Hello.

Is there anyone with the similar issue?

Thank you

It has to do something with this?

As of quic-go v0.19.x, you might see warnings about the receive buffer size.

Experiments have shown that QUIC transfers on high-bandwidth connections can be limited by the size of the UDP receive buffer. This buffer holds packets that have been received by the kernel, but not yet read by the application (quic-go in this case). Once this buffer fills up, the kernel will drop any new incoming packet.

Therefore, quic-go tries to increase the buffer size. The way to do this is an OS-specific, and we currently have an implementation for linux, windows and darwin. However, an application is only allowed to do increase the buffer size up to a maximum value set in the kernel. Unfortunately, on Linux this value is rather small, too small for high-bandwidth QUIC transfers.

non-BSD

It is recommended to increase the maximum buffer size by running:

sysctl -w net.core.rmem_max=2500000

This command would increase the maximum receive buffer size to roughly 2.5 MB.

I have set this to my SYNOLOGY DSM but did not helped.

Hey, just got here - having the same problem. Did you figure out a fix in the end? Please let me know!

Unfortunately at this moment nor STROJ or SYNOLOGY support could not helped me. This is definitely issue between SYNOLOGY and Docker after last DSM update. Someone should check this. TCP is works but there is issue with QUIC via UTP.

I have recevied this answer from SYNOLOGY support:

Dear Customer,

Thank you for the patience in waiting.

From my discursion with the developers, I am sorry, there is little we can do about the situation. I was informed that, the Synology does not officially (currently) supports QUIC. Docker being an open source package, I have checked through the documentation without being able to find any information relating to the Network settings.

I will suggest that you contact Storj for more information on why the issue occurred and how to prevent such in future.

Do not hesitate to contact me, if you have any further questions.

Best Regards,

O. Medahunsi
Technical Support Engineer

I have some not so overwhelming news about Synology on Docker. The Synology Docker package is a distribution maintained by Synology, even though they like to claim otherwise. It is modified to support DDSM and to make it compatible with other libraries Docker depends on (like the btrfs implementation), which of course are modified as well. After all it’s an appliance style of os, so it’s fair game to modify it as they see fit. They don’t claim it to be a Linux distribution.

Thanks to all the modifications Synology did to their whole ecosystem, it is impossible to replace Synology’s docker binaries with the generic docker linux binary release.

I guess if someone will be able to help, it will be somone from STORJ who knows which kernel (or whatever) settings are required.

1 Like

Well I was not able to find DDOS setting on my router. But on forum I have found that maybe this is it:

I have disabled it and recreated first node on my DSM and Docker and whoa :open_mouth:

Can believe it that this was the issue (maybe not) because this started by DSM update and did not go away after router change and tried lot of settings. I have tried even remove all NAT port FW rules and keep running only one node on DSM and one rule on router (still issue).

Finally I have Two Greens!!! :star_struck:

I forgot to tell you to disable all the malware protections in your router. My Asus addons from TrendMicro interfers with the SN too. Please disable the first option too.

Thank you everyone for help and cooperation. Much appreciate :slight_smile:

Wigo

1 Like