Docker Community Forums

Share and learn in the Docker community.

Attempt to join docker swarm with windows fails with " Unhealthy UCP Node: invalid mount target, must be an absolute path: /var/run/docker.sock"

I am really really having issues with this and cannot find a solid set of instuctions to do this

I have an existing swarm running on Ubuntu 14.04 running Docker Server Version: 1.12.3-cs4

I am attempting to join a windows 2016 server to the swarm

I run this

docker@docker-datacenter-demo-1:~$ docker swarm join-token worker
To add a worker to this swarm, run the following command:

docker swarm join \
--token SWMTKN-1-2tnc2zu4aink3bln3jvmg4jid4s3ouw0edavl2j3i49fq7tk7r-7mehg3y2i85nflvp2ih8z1r8f \
192.168.56.51:2377

I copy and paste this into the windows 2016 server and it seems to work

C:\Users\Administrator>docker swarm join --token SWMTKN-1-2tnc2zu4aink3bln3jvmg4jid4s3ouw0edavl2j3i49fq7tk7r-7mehg3y2i85nflvp2ih8z1r8f 192.168.56.51:2377
This node joined a swarm as a worker.

however when I look at this in the UCP I see this

“Unhealthy UCP Node: invalid mount target, must be an absolute path: /var/run/docker.sock”

.

UCP is not expected to work with Windows nodes yet, sorry.

yep , I looked at the command line and I see this with a docker node ls

I was able to see my node from here but not in the UCP , this is expected for now I guess , for the record i ran these on the windows 2016 server to open the required ports

Netsh advfirewall firewall add rule name=“docker daemon” dir=in action=allow protocol=tcp localport=2375 enable=yes

Netsh advfirewall firewall add rule name=“docker overlay1” dir=in action=allow protocol=udp localport=4789,7946 enable=yes

Netsh advfirewall firewall add rule name=“docker overlay2” dir=in action=allow protocol=tcp localport=7946 enable=yes

Hi @friism,

Is there any update on this topic? I saw here that there is a possibility to add Windows Server 2016 worker nodes to a Docker UCP installation.

But it also says :

“Please work with your account representative to join the Windows Early Access program and they will provide additional details on how to install UCP to enable Windows support.”

How exactly do we join the Windows Early Assess program? Is it open for everyone? Which account representative do we have to contact (Docker or Windows)?

Thanks for any help