Docker Community Forums

Share and learn in the Docker community.

AWS install error for docker 1.13 - Requires: selinux-policy-targeted >= 3.13.1-102

aws
amazonwebservices
upgrades

(Jimzucker) #1

Hi,

I am trying to install docker 1.13 on a new AWS LInux AMI.

I followed the instructions on : https://docs.docker.com/engine/installation/linux/centos/#install-using-the-repository

but got a host of errors for dependencies. I worked through them but cant solve the last one:

[ec2-user@ip-172-31-36-105 ~]$ sudo yum install docker-ce.x86_64 --skip-broken
Loaded plugins: priorities, update-motd, upgrade-helper
Resolving Dependencies
–> Running transaction check
β€”> Package docker-ce.x86_64 0:17.03.1.ce-1.el7.centos will be installed
–> Processing Dependency: selinux-policy >= 3.13.1-23 for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: docker-ce-selinux >= 17.03.1.ce-1.el7.centos for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: systemd-units for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit) for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: libsystemd.so.0()(64bit) for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Running transaction check
β€”> Package docker-ce.x86_64 0:17.03.1.ce-1.el7.centos will be installed
–> Processing Dependency: selinux-policy >= 3.13.1-23 for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: systemd-units for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit) for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
–> Processing Dependency: libsystemd.so.0()(64bit) for package: docker-ce-17.03.1.ce-1.el7.centos.x86_64
β€”> Package docker-ce-selinux.noarch 0:17.03.1.ce-1.el7.centos will be installed
–> Processing Dependency: selinux-policy-base >= 3.13.1-102 for package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch
–> Processing Dependency: selinux-policy-targeted >= 3.13.1-102 for package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch

Packages skipped because of dependency problems:
docker-ce-17.03.1.ce-1.el7.centos.x86_64 from docker-ce-stable
docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch from docker-ce-stable
[ec2-user@ip-172-31-36-105 ~]$ docker yum install docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch
-bash: docker: command not found
[ec2-user@ip-172-31-36-105 ~]$ bbb^C
[ec2-user@ip-172-31-36-105 ~]$ sudo yum install docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch
Loaded plugins: priorities, update-motd, upgrade-helper
Resolving Dependencies
–> Running transaction check
β€”> Package docker-ce-selinux.noarch 0:17.03.1.ce-1.el7.centos will be installed
–> Processing Dependency: selinux-policy-base >= 3.13.1-102 for package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch
–> Processing Dependency: selinux-policy-targeted >= 3.13.1-102 for package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch
–> Finished Dependency Resolution
Error: Package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch (docker-ce-stable)
Requires: selinux-policy-targeted >= 3.13.1-102
Available: selinux-policy-targeted-3.10.0-98.26.amzn1.noarch (amzn-main)
selinux-policy-targeted = 3.10.0-98.26.amzn1
Error: Package: docker-ce-selinux-17.03.1.ce-1.el7.centos.noarch (docker-ce-stable)
Requires: selinux-policy-base >= 3.13.1-102
Available: selinux-policy-minimum-3.10.0-98.26.amzn1.noarch (amzn-main)
selinux-policy-base = 3.10.0-98.26.amzn1
Available: selinux-policy-mls-3.10.0-98.26.amzn1.noarch (amzn-main)
selinux-policy-base = 3.10.0-98.26.amzn1
Available: selinux-policy-targeted-3.10.0-98.26.amzn1.noarch (amzn-main)
selinux-policy-base = 3.10.0-98.26.amzn1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


(Michael Friis) #2

Unfortunately, Docker Inc. does not support or ship Docker CE packages for AWS Linux. You can install packages maintained by AWS with sudo yum install -y docker. I don’t know what version they currently have.


(Mariner) #3

You mean Amazon Linux? So what AMI do you suggest to use with Docker?