Docker Community Forums

Share and learn in the Docker community.

/bin/sh:1 :sudo: not found docker toolbox for windows 7


(Iaarya) #1

Hi All,
I have recently installed Docker toolbox for windows 7.
I also ran docker hello world and tutorial (https://docs.docker.com/engine/getstarted/step_four/) both of which seem to run fine.
I later tried to execute this (https://github.com/CAIsr/volgenmodel-nipype) by cloning the respective git hub repository (this already contains the necessary docker file for its execution).
I tried to build this repository, but in the middle of the build I ended up with this error message:

Step 13 : RUN sudo make install
—> Running in 89b475dd00b3
/bin/sh: 1: sudo: not found
The command ‘/bin/sh -c sudo make install’ returned a non-zero code: 127

I am not sure how to resolve this error message, as I am fairly new to Docker
If someone can point me towards the right direction.

My docker info is as follows:
$ docker info
Containers: 57
Running: 0
Paused: 0
Stopped: 57
Images: 33
Server Version: 1.12.1
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 153
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: host null bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.17-boot2docker
Operating System: Boot2Docker 1.12.1 (TCL 7.2); HEAD : ef7d0b4 - Thu Aug 18 21:18:06 UTC 2016
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 995.9 MiB
Name: default
ID: WC2N:YBDF:MYGU:TS4A:IFUY:GWH4:GO5Y:ZCCG:7PZI:FC5B:4CJE:QOAQ
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: 17
Goroutines: 28
System Time: 2016-09-12T23:04:17.083964322Z
EventsListeners: 0
Registry: https://index.docker.io/v1/
Labels:
provider=virtualbox
Insecure Registries:
127.0.0.0/8

Thanks for your help in advance.
Kind regards