Docker Community Forums

Share and learn in the Docker community.

Installation of docker toolbox not working on windows 7


(Reier) #1

trying to install on Lenovo Thinkpad W520 with disk encryption.

Installed docker on windows
https://docs.docker.com/windows/step_one/

Hardware assisted virtualization is not enabled on this computer

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/Lenovo-Thinkpad-w520-Virtualization-Technology-How-to-enable/ta-p/520017 Press F1 on startup

If virtualization is not enabled on your system, follow the manufacturer’s instructions for enabling it on IBM Lenovo W520. So did that and initial problem disappeared.

“C:\Users\IBM_ADMIN\AppData\Local\Programs\Git\bin\bash.exe”
–login -i “C:\Program Files\Docker Toolbox\start.sh”, have to change bat file for Docker quickstart.
The problem is that git is by DEFAULT installed in directory not assumed by Docker.
But I solved that by changing bat file.

But then the serious trouble started…
After that, started DockerQuickstart. First attempt failed.

Unable to get the latest Boot2Docker ISO release version,trying that twice.

Copying
C:\users\IBM_ADMIN.docker\machine\cache\bootdocker.iso to …

Creating VirtualBox VM…
Creating SSH key…
Starting the VM…
Check network to re-create if needed…
Waiting for an IP… (and wait forever)

Second attempt: Error getting IP address. Something went
wrong running an SSH command! Command: ip addr show dev eth1.

err: exit status

I followed the troubleshooting guide, did not help much:

Docker run hello-world: An error occurred trying to connect
…, no connection could be made because the target machine refused it.

Docker regenerate certs: Does not work at all, hands on waiting for SSH to be
available

Docker-machine restart default: Just hanging forever…

Docker-machine ls: The only command that actually works.

Removing VM in virtualbox (stopping and removing). I googled
the actual error message SSH problem, and this was one of the solutions to the
problem: First delete, then restart.

Started Docker quickstart again.

Similar problems, and even worse. Other programs on my PC stopped working
(like word, Lotus Notes). So had to reboot.

Any suggestions? I have googled the ssh error, and no of the suggestions found there helps anything. I am new to Docker, so it is very unfortunate that I run into hopeless problem just following the installation procedure. I have also tried with “run as administrator”. Does not help.


(Eric Ti-Yu Chiang) #2

The removing vm in virtualbox solution, is it this?

$ docker-machine rm default
$ docker-machine create --driver virtualbox default

I found it from this docker toolbox issue discussion. Thanks.


(Ivan7707) #3

One one of my work machines I have had horrible problems with installing docker. It is a laptop that has windows 7 on it. My office desktop with windows 7 installed docker just fine.

How I was able to install docker is login as the administrator user of the machine and run the exe file. It works fine now within the administrator user, but when I switch back to my normal user, there are still issues. Weird thing is that my user is in the admin group, but I have to login to the administrator account to run docker properly.

I think the problem lies with either permission issues or with the something with the setup of the laptop in our network environment.

Hope that helps someone.

Ivan


(Nathan Le Claire) #4

Make sure to manually remove any VirtualBox host-only networks in the GUI if you have issues in this area (sometimes this causes VBox to fall over).

If you’re in a restrictive network, e.g. VPN or proxy, you may have to get “creative”, e.g. add the VM routes yourself manually. There’s only so much Toolbox can do when a VPN with administrator access is sitting re-directing routes to the local VM away.


(Nathan Le Claire) #5

BTW, if initial create fails, the state of the half-created VM is much less likely to be salvageable than looking into why create doesn’t quite succeed in the first place. As another poster mentioned always try re-creating first, and try to debug create specifically if it still will not succeed. regenerate-certs et al. are meant for already “healthy” VMs.

Also, it is really intended to use the Toolbox without administrator permissions, if you create and start poking at VMs with admin access, it’s likely to cause issues if you’d like to switch back to managing them as a regular user.