Binding ports to localhost

Hi there.

I’ve been building a docker image for months, and using it with a compose file to publish its ports (3000) to localhost.
Now it doesn’t work, the only way to see my app is to find the network used by docker (e.g. and on this interface it indeed shows up. I can’t find what has changed. Maybe I am doing something wrong (without noticing the change in my protocol) or maybe there has been a change in docker’s way of handling that…

The compose file specifies the port mapping:

    - "3000:3000"

When using the docker command flags (e.g. -p "3000:3000") the behaviour is the same: I can access the app on 172.x.x.x:300 but not on the host’s interface (e.g. localhost:3000).

It worked well until last week. What happened?

P.S.: the image is open-source btw, it can be found here:

Any help would be appreciated. Thanks, have a great day! :slight_smile:


It works now; the only updated thing is I have removed all containers and restarted the whole thing with a clean setup. I’m happy, but I’d love to understand what happened and if we are supposed to get bindings on localhost…

Waiting a bit before closing the request, just in case SomeoneKnows ™.

Have a great day!