Docker Community Forums

Share and learn in the Docker community.

Bug report: automated build not matching Github tag with regex

I was trying to use Automated Builds from Github tag source that match a simple regex /^v([0-9.]+)/ but the match never succeeded.

There is a tag named v0.8.2-alpha on Github, From the screenshots below you can see that when I set the source tag name to the exact same tag name v0.8.2-alpha (without regex), it can find out the tag and shows “trigger” button. However, when I add another rule that matches regex /^v([0-9.]+)/ (which should match tag name v0.8.2-alpha), the “trigger” button never shows up. I tried switching between branch and tag, use webhook to manually trigger, toggling build caching, or click the save and build button, but none of them works.

What may be relevant is that, if I tried to change all “/” to “” so the regex becomes ^v([0-9.]+), the trigger button shows up, but the build will immediately fail without even show up in the “recent builds” section.

I am pretty sure your tag regexp is fine.

I had the same problem and played arround with the webhook settings for my github repo. I additionaly checked “Branch or tag creation” and saved the change.

Then I created a new tag matching my regexp and suddenly Dockerhub is building the image.

The only thing that worries me: Dockerhub has permissions to modify the Webhook in Github for our needs. Why didn’t it do so by itself?

I tried that but still no luck :frowning:

Did you create a new tag after enabling “Branch or tag creation”?

Yes I did. I can even see it appears in the webhook sending history on Github, but nothing happens on the Docker Hub side.