Docker Community Forums

Share and learn in the Docker community.

New Git tag does not trigger automatic build anymore

build
automatedbuilds

#1

I just pushed a new Git tag to a GitHub repository of mine and noticed that the automatic build feature stopped working for me. I am using the “match versions” build rule from the “example build rules” in the “Build settings” section:

  • Type: Tag
  • Name: /^[0-9.]+$/
  • Dockerfile location: /
  • Docker Tag Name: {sourceref}

My most recent Git tag is “0.1.3”, which should be matched by the Regex.

Here’s a screenshot of my build rules:

Note: When I push to my GitHub repo, the “latest” build rule is triggered, so my GitHub Webhook seems to be working fine.

Does anybody have any idea on how to solve this?


(Daniel Brown) #2

Same Issue here! The “build on new tag” feature doesn’t seem to work anymore.

It must have something to do with the consolidation of docker cloud and docker hub: https://blog.docker.com/2018/12/the-new-docker-hub/

I tried to configure a classic build (https://docs.docker.com/docker-hub/builds/classic/) but that doesn’t work either…

My current workaround is manually creating a new Build Rule for every new tag.


(Daniel Brown) #3

Nevermind, the feature seems to work again for me.
I had to configure an Automated Build (not “Classic”):


#4

I was not aware that the Build Rules I had created were “Classic” Automated Builds.

So apparently in order to create Automated Builds now, I have to link my Docker Hub account to my GitHub account, right?


#5

@djbrown: Where did you configure your non-Classic Automated Build?

I linked my GitHub account and deleted all previous build rules, but my build rules interface still looks the same (no “Autobuild” and “Build caching” settings visible).


(Daniel Brown) #6

You can manage your Docker Repository’s Build Triggers on Docker Cloud at https://cloud.docker.com/repository/docker/USERNAME/REPONAME/builds/edit.
For example for my Repo I go to https://cloud.docker.com/repository/docker/djbrown/hbscorez/builds/edit.

You should also be able to navigate there via UI by goiing to your Repo on Docker Cloud > Builds > Configure Automated Builds (see screenshot).

Maybe you also have to delete Docker Hub and/or Docker Cloud integrations from GitHub.
You can also try to turn off Classic Automated Builds (deselect “When active, builds will trigger automatically on push actions.” under Build Settings section).