Docker Community Forums

Share and learn in the Docker community.

Build hangs since ours in "Pending"

Since the last couple of ours two builds i queued are hanging in “Pending” state.
They don’t seem to start.

Usually it took about a couple of minutes to start and then after 2 minutes to build.

Two builds I wanted to cancell now they are showing chanceling since hours…
Any advice whats wrong?

We’ve been having the same issue, yesterday and now today with another repo. Have a stack 6 pending builds that we’ve tried to cancel but it’s stuck. I think there needs to be a way to ‘reset’/clear out the build workspace.

How have you managed the issue?

We are facing exactly the same issue. In our case it’s just for one branch (other’s build just fine) that keeps on gathering pending jobs on it’s queue. Apparently the commit that caused this problem failed it’s build, but the Docker Hub didn’t manage to change the jobs status. Consequent pending jobs can be cancelled, but the problematic one shows for a second it’s cancelling and then it’s right back to untouched Cancel button. It also doesn’t show it’s commit ID or tag on the Builds tab. Tried launching the build job on that branch manually, and it eventually reported a FAILED status, though any new commits still appear as pending.

As a hotfix we started making the builds for that branch locally, tagging them, and pushing them to Docker Hub. (That still launches appropriate webhooks for consequent CD.)

Greetings. We’re facing the same issue with another of our repositories. :frowning:
Thank you for fixing the previous one! This time it’s been jammed for five days already.