Docker Community Forums

Share and learn in the Docker community.

Building 'getting-started' tutorial app never completes

New to Docker and have just installed it on Windows. Trying to work through the ‘getting-started’ tutorials here Sample application | Docker Documentation
when I run the following build command it runs for a long time and then eventually hangs:

Docker version is 3.5.1. Windows version is 20H2 (OS Build 19042.1083). WSL 2 is installed and running:
image

Should it eventually complete? How long should it take?

Update:
Seems like the engine crashed because ‘docker version’ stopped reporting a server - client only. I tried restarting Docker using the ‘Restart Docker…’ menu option from the tray and now it is reporting “Error response from daemon: open \.\pipe\docker_engine_linux: The system cannot find the file specified.” from ‘docker version’:

there appears to be various solutions to this problem, try these:

restart docker desktop

cd “c:\program files\docker\docker”
./DockerCli.exe -SwitchLinuxEngine

Update the linux kernel in Windows (Install WSL on Windows 10 | Microsoft Docs)

try running Net stop com.docker.service and then Net start com.docker.service in Powershell