Docker Community Forums

Share and learn in the Docker community.

Docker Desktop cannot start the service

I’m currently meeting a problem when trying to use Docker on Windows.
Last week, I could use Docker in WSL normally, and the Docker deamon started automatically on startup.

However, this week, I cannot use Docker on WSL, and the error message is:
Cannot connect to the Docker daemon at tcp://localhost:2375. Is the docker daemon running?

So, I start the Docker by opening the Docker Desktop, and I can see it’s starting:
start

However, it just hangs there for a while, and then just disappears. No error message is shown. The daemon still hasn’t started, and there’s no way to start it.

I have tried uninstalling or updating the Docker, but nothing works. The installer just hangs forever, so nothing can be done.

My Docker version: Docker version 19.03.12, build 48a66213fe
My Windows version: Major 10, Build 18362

What version of Docker Desktop do you use?
I had similar problems not so long ago, but it always worked when I started Docker Desktop a second time. Since I’ve installed the new Win 10 insider preview (now I’m at build 20190) Docker never failed to start.

This is the output of “docker version” command.

Client: Docker Engine - Community
 Version:           19.03.12
 API version:       1.40
 Go version:        go1.13.10
 Git commit:        48a66213fe
 Built:             Mon Jun 22 15:43:18 2020
 OS/Arch:           windows/amd64
 Experimental:      false

Docker version gives you the version of the Docker command line. You get the version of Docker Desktop for example with

PS> Get-ItemProperty HKLM:\Software\Microsoft\Windows\CurrentVersion\Uninstall\* | select DisplayName,DisplayVersion | where {$_.DisplayName -like "*Docker*"}

Then, the version of my Docker Desktop is 2.3.0.4.