Docker Community Forums

Share and learn in the Docker community.

Can docker-ce support newest version of kernel (4.12.8)?


(Yncxcw) #1

hi, all

I have run docker-engine(the old version) for a while. Today I tried to test docker engine on newest kernel, 4.12.8 and found the docker failed to start after the system started.

I manually compile the kernel and the OS-distribution I used is ubuntu 16.04-xenial.

Then I just uninstall the old version of docker and installed the new docker-ce.
The problem reported by apt-get install is shown below:

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
docker-ce
0 upgraded, 1 newly installed, 0 to remove and 16 not upgraded.
Need to get 21.0 MB of archives.
After this operation, 99.6 MB of additional disk space will be used.
Get:1 https://download.docker.com/linux/ubuntu xenial/stable amd64 docker-ce amd64 17.09.0~ce-0~ubuntu [21.0 MB]
Fetched 21.0 MB in 0s (23.1 MB/s)
Selecting previously unselected package docker-ce.
(Reading database … 453251 files and directories currently installed.)
Preparing to unpack …/docker-ce_17.09.0~ce-0~ubuntu_amd64.deb …
Unpacking docker-ce (17.09.0~ce-0~ubuntu) …
Processing triggers for systemd (229-4ubuntu21) …
Processing triggers for ureadahead (0.100.0-19) …
Processing triggers for man-db (2.7.5-1) …
Setting up docker-ce (17.09.0~ce-0~ubuntu) …
Job for docker.service failed because the control process exited with error code. See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Tue 2017-11-14 17:45:54 MST; 8ms ago
Docs: https://docs.docker.com
Process: 10618 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
Main PID: 10618 (code=exited, status=1/FAILURE)
Tasks: 23
Memory: 3.1M
CPU: 84ms
CGroup: /system.slice/docker.service

Nov 14 17:45:54 disco-0021 systemd[1]: Failed to start Docker Application Container Engine.
Nov 14 17:45:54 disco-0021 systemd[1]: docker.service: Unit entered failed state.
Nov 14 17:45:54 disco-0021 systemd[1]: docker.service: Failed with result ‘exit-code’.
dpkg: error processing package docker-ce (–configure):
subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

So, if the error is caused by the incompatibility for newest version of kernel or by lacking configuration options which I should have done at “make menuconfig” ???

Appreciate all your help and comments…

Thanks!

Wei


(Yncxcw) #2

hi,all

Problem is solved, it is caused by some dependent issues from old version of docker engine. After I delete the /var/lib/docker and then re-install the docker-ce, the problem is solved. However, all my old images get lost

Wei