Can not share drives in Windows 10 Anniversary Edition

Expected behavior

Drive is shared so that I can mount volumes in the VM

Actual behavior

Can’t share drives since I keep receiving this message all the time:

I have disabled the restriction as shown in this pic:


Windows 10 Anniversary Edition

Steps to reproduce the behavior

  • Open the Docker for Windows settings dialog
  • Click Manage shared drives
  • Select any drive (in my case were D and E)
  • Click OK

The message for the Windows restriction appears all the time, I have restarted my system but that doesn’t make the difference. I’m unable to mount a drive as a result. I need to use local files as I’m using this for development.