Cannot connect to daemon after power outage

Docker all set up, pulled dream factory and all set up and running fine for a few days. After a power outage this morning and a hard reboot, I get the following error. I’ve added the diagnostic id

DreamFactory container not running "cannot connect to docker daemon

Diagnostic Id

Is this the older version that uses VirtualBox? If so, try this:

docker-machine start

Otherwise if it’s the new one that runs natively, look for the docker icon on the top bar of your screen, click on it, and that will tell you if docker is running.

Apologies for the brief post. I thought the “diagnostic Id” would be a way to provide more info.

Its the new version and the docker green light is on. The error seems to be something to do with docker.sock. See below. Everything worked fine before the outage, so I am guessing some kind of corruption of the install.

Docker for Mac: version: mac-v1.12.0-beta20 OS X: version 10.11.5 (build: 15F34) logs: /tmp/20160728-192854.tar.gz failure: docker ps failed: Failure("docker ps: timeout after 10.00s") [ERROR] docker-cli /var/run/docker.sock does not exist Permission denied (EACCES) connecting to /var/run/docker.sock: check permissions docker ps failed [OK] app [OK] moby-syslog [OK] virtualization [OK] menubar [OK] system [OK] osxfs [OK] db [OK] slirp [OK] moby-console [OK] logs [OK] vmnetd [OK] env [OK] moby [OK] driver.amd64-linux

Sorry, I have no idea! I’d probably re-install if it’s not too painful.

Tried reinstall – get the same error, but thanks anyway.

I know this thread is a little old, but I’ve encountered the same issue and reproduced it just today. Had docker with some containers running for days. Over the weekend there was a power loss. Came in, restarted the machine, and tried to access docker commands. Got “Cannot connect to the Docker daemon. Is the docker daemon running on this host?”

I couldn’t figure it out so I ended up wiping the machine and reinstalling docker. It took a little over an hour and I knew I could get it done quickly.

However, as a test I setup another machine which had the same configuration and docker containers running. I pulled the plug on it. Upon reboot, the same cannot connect to the Docker Daemon error has occurred.

My OS is Ubuntu Core 15.04. Both boxes are identical hardware and software configurations.

EDIT: Update: Uninstall of docker and reinstall fixed it. Didnt need to wipe everything. But still would like a better solution. Perhaps there’s a lock file somewhere that doesnt get reset