Docker Community Forums

Share and learn in the Docker community.

Cannot connect to the Docker daemon. Is 'docker -d' running on this host?


(Corck) #1

I have the problem that I just cannot connect to docker as normal user. I’ve googled everything but fail to get it working.
My user is in the docker group, the socket has the docker group, apparmor installed. Nothing works.

Am runnung Kubuntu 14.04. Tried it with the latest Docker 1.7.1 and 1.6.2. Followed the official Ubuntu instructions.

running as root works fine.

ckDev@w520 ~ % docker run hello-world
Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
1 ckDev@w520 ~ % ps -ef | grep docker                                                                                             :(
root      3044     1  0 09:29 ?        00:00:00 /usr/bin/docker -d
ckDev     6553  6470  0 10:14 pts/0    00:00:00 grep --color=auto docker
ckDev@w520 ~ % groups
ckDev sudo lpadmin scanner vboxusers docker
ckDev@w520 ~ % ls -al /var/run/docker.sock 
srw-rw---- 1 root docker 0 Jul 22 09:29 /var/run/docker.sock=
ckDev@w520 ~ % sudo docker run hello-world
Hello from Docker. .... 

thx


(Ralph Kincade) #2

have you logged out and logged back in ??? :smile:


(Corck) #3

… surely! I can even touch the socket.


(Ralph Kincade) #4

I have not installed apparmor with my docker so I dont know how it could effect this , but can you create another instance of docker with out apparmor installed to see what happends ?


(Corck) #5

Apparmor is installed on Ubuntu, and there are threads that there was a bug that docker depends on it. Therefore I mentioned it. I even tried to disable it, but did not help.