Docker Community Forums

Share and learn in the Docker community.

Cannot create docker network

Summary:

Issue Type: Cannot create docker network
OS Version: Windows 10 - 10.0.17134
Docker Version: 18.09.2

Steps to Reproduce:

The following command:

docker network create MyNetwork -d transparent

gives the following error:

Error response from daemon: could not find plugin Transparent in v1 plugin registry: plugin not found

Details:

A few weeks ago ran the above command and it worked. Then, this week, I decided to try out minikube. A getting started tutorial for that had me run a command called New-VMSwitch.

New-VMSwitch was not working. (It was saying that "only one’ Virtual Switch could be turned on. I guessed that the newtork made for docker was in the way. So, I deleted that network. After doing that, theNew-VMSwitch command worked!

But now I want to go back to docker. So I turned off minikube and am trying to put the network back. But I am getting the above error.

Things I have tried:

  • Reboot my dev machine.
  • Reset Docker to factory settings
  • Variations of the docker network create command (they all fail with a variation on the above error.)

Anyone have any suggestions for me?

Switching from Windows to Linux and then back to Windows seems to have fixed it.