Cannot get Docker Desktop to run on Ubuntu 24.04

Hi, been at this a few days now.

I upgraded to Ubuntu 24.04. I tried installing Docker Desktop and that would not run. No errors, just hangs.

Many many cleans and reinstalls later. Even docker hello-world wont run.

The error message I get is that the daemon wont start.

Cannot connect to the Docker daemon at unix:///home/greg/.docker/desktop/docker.sock. Is the docker daemon running?.

Shouldnt this be looking at /var/run/docker ?

docker info
Client:
Version: 24.0.7
Context: desktop-linux
Debug Mode: false
Plugins:
buildx: Docker Buildx (Docker Inc.)
Version: v0.14.0
Path: /usr/libexec/docker/cli-plugins/docker-buildx

Server:
ERROR: Cannot connect to the Docker daemon at unix:///home/greg/.docker/desktop/docker.sock. Is the docker daemon running?
errors pretty printing info

1 Like
  • Have a 64-bit version of either the latest LTS version (Ubuntu Jammy Jellyfish 22.04) or the current non-LTS version (Ubuntu Mantic Minotaur 23.10). Docker Desktop is supported on x86_64 (or amd64) architecture.

Ubuntu 24.04 is still beta and not mentioned among the supported operating systems. I still haven’t installed Ubuntu 24.04 so I have no idea whether Docker Desktop should work on it or not.

When you start the GUI? Did you try to check system logs?

The GUI doesnt start. Thats the problem.

Doesn’t just show “loading” but doesn’t start at all?

Either way, without logs there is nothing I can say unfortunately. And I don’t use DD for Linux enough to know what could go wrong. Have you tried Docker Desktop for Linux on supported Ubuntu versions as well?

Yes. I used Docker Desktop on previous version of Ubuntu no problem

Any luck here yet? I have the exact same problem. Ubuntu 24.04 Docker Desktop doesn’t start. When clicking on the icon, no reaction. No Loading or errors or any reaction.

Yeah. Docker desktop not working yet on ubuntu 24.04. Please help

I have the same issue and I just upgraded to ubuntu 24.04
I want to roll back to 23 and try again

event the docker-cli is not working in ubuntu24.04

Same for me… I think we will have to wait for a new version?

I had the same error with Docker Engine so the cause might not be the same, but I’d previously set the service to depend on a network mount, which had seemingly been renamed during the upgrade. Try starting it from the terminal and see if it complains about a mount point not being found:

$ sudo service docker start
Failed to start docker.service: Unit media-share.mount not found.

If that’s the case, you can run systemctl list-units --type=mount to get the updated name, then edit /etc/systemd/system/multi-user.target.wants/docker.service and edit the [Unit] block appropriately. There’s probably a way to reload changes but I did a reboot and docker came straight back up.

Hope that helps someone!

That’s what I don’t think you can with Docker Desktop and even if you could, that is a virtual machine so you wouldn’t see the logs of the daemon.

I see many of you have problems, but have any of you checked whether Docker Desktop is supported on Ubuntu 24.04 before you upgraded to it? See my previous reply

And where does it mention Ubuntu 24.04?

Its doesnt but they would not just drop docker support without a statement to that effect.

It doesn’t mean they dropped it, but since the new LTS has many changes, they might have delayed a release that supports it. 24.04 is still pretty new, although they could have started to support it while it was beta. I don’t know the reasons, but you can join the discussion on GitHub:

Will do thanks a lot

I have also tried with 24.04 LTS version. The GUI is not starting at all. When It will be available or how to resolve this error.

1 Like

Docker desktop won’t work and it probably needs an update. But docker engine works but ONLY with sudo. So from what I have experienced docker ps will give you an error that can’t connect to docker service but sudo docker ps works.

I think it has something to do with the new security features of Ubuntu 24.04 here https://ubuntu.com/blog/whats-new-in-security-for-ubuntu-24-04-lts. It’s just sad that Docker didn’t even try to fix this between the time of the beta release and the final release. They had 2 weeks time and nobody at Docker thought about testing it on 24.04?

1 Like

Depends on the context. See docker context --help. If you have Docker DEsktop and Docker CE, you need to switch between contexts. If your user is not in the docker group, then indeed, you need to use sudo. When you use sudo, it will always use the default context since Docker Desktop’s context will not be available as root.

We don’t know if they tried or not. The best that all of you can do is join the conversation in the issue on GitHub. And again, next time don’t upgrade an OS when you don’t know if all of the requirements are supported on the new one :slight_smile:

But thanks for the link. I will read it later after work.