Docker Community Forums

Share and learn in the Docker community.

Cannot install a specific version; Version '18.03.0.ce' for 'docker-ce' was not found

I’m trying to install Docker on Ubuntu runnning on Windows. I followed the instrunction here https://docs.docker.com/install/linux/docker-ce/ubuntu/#install-docker-ce-1 and I could see the lists of docker available like docker-ce | 18.03.0~ce-0~ubuntu and I tried to install a specific version as the instruction does. But when I input the command sudo apt-get install docker-ce=18.03.0.ce this error E: Version '18.03.0.ce' for 'docker-ce' was not found occured?
How am I wrong with this?

Yes, about the same with my problem. Any person could help us ?

Hey @spiderhand my problem solved, the script that you follow is not complete yet. You can use this full script: " apt-get install docker-ce=18.03.0~ce-0~ubuntu-xenial" . Hope it works! *Note: script “ubuntu-xenial” it depends on your OS. CMIIW

This thread is more than a year old, but I am having the same issues. I had installed Bionic, Ubuntu 18.04, and followed Docker’s instructions. but no install for docker-ce was found.

I uninstalled 18.04 and installed ubuntu 16.04. Again, following Docker’s instructions, still no luck. I then saw @trisnawirdan’s comment and tried that. Still no luck.

How do I get this installed?

Check the output of apt-cache madison docker-ce and use apt install docker-ce={version number in 2nd column of previous output} to install the specific version.

I don’t remember exaclty when the docker-ce package was split into docker-ce and docker-ce-cli, though make sure both are uninstalled before you install an older version. An existing docker-ce-cli with a new version number will prevent the installation of an older docker-ce package…