Docker Community Forums

Share and learn in the Docker community.

Unable to Display Docker Version Correctly

I’m trying to install a specific version of docker engine for Kubernetes




Everything looks good until I try to list the avaliable docker version so I can download it
When I ran this command, “apt-cache madison docker-ce”, I do not get anything back. Not even an error.


So I did everything over again but this time when I set up the stable repository, I add the word “nightly” in.
sudo add-apt-repository “deb [arch=amd64] https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable nightly


Now when I run “apt-cache madison docker-ce”. I get this

docker-ce/disco 5:19.03.0~1.2.beta2-0~ubuntu-disco amd64
docker-ce/disco 5:19.03.0~1.1.beta1-0~ubuntu-disco amd64
docker-ce/disco 5:0.0.0-20190604210709-946ce19cf7-0~ubuntu-disco amd64
docker-ce/disco 5:0.0.0-20190604010150-6f8ce5be9c-0~ubuntu-disco amd64
docker-ce/disco 5:0.0.0-20190602210104-8bc6c6593a-0~ubuntu-disco amd64
docker-ce/disco 5:0.0.0-20190530210241-55077c3776-0~ubuntu-disco amd64

Docker version 5.0.x. This can’t be right? What am I doing wrong??


thanks