Docker Community Forums

Share and learn in the Docker community.

Cannot install Docker CE on Ubuntu 18.04 or Debian 10

Hi! I’m trying to install Docker CE as per the instructions here: https://docs.docker.com/install/linux/docker-ce/debian/

I have tested it on Ubuntu and Debian, but on both if fails like this:

E: Failed to fetch https://download.docker.com/linux/ubuntu/dists/bionic/pool/st                                                                                                             able/amd64/containerd.io_1.2.13-1_amd64.deb  Hash Sum mismatch
   Hashes of expected file:
    - SHA512:45640591cd629a357cdf4ab3b5225dd8c4ce3f7100ab35b776502224014c76db164                                                                                                             f849f52bf044919b01a4acbb075a11aacc514d386af398c6f93ba7ef35e2e
    - SHA256:e0f9d311a77ce0729a25f41925f6b3174616f704fd21bbc7c4d91a1012f360a8
    - SHA1:4c7a98e8145fb258c24044c78f6f1f8abc1f6893 [weak]
    - MD5Sum:7eaf2d7d924a20d6fbf1ce8cd155b67e [weak]
    - Filesize:20144902 [weak]
   Hashes of received file:
    - SHA512:b0576a9f4b081aeb570892d5ae4d59dfde0f170e0c5b120afef7c8dacdcd32a41ef                                                                                                             5eab5ecb0fdddbad4cf866e15193a5469f468574d0a34cf1f3db15b172cd4
    - SHA256:83b666eefb09ca1f3c9cc9d8d032fb3e465a7ff83f9d32a322ee2f53c54cf6f3
    - SHA1:2db2184f1f4b1ad4ee1266a70eafcc7603a72da8 [weak]
    - MD5Sum:e3f890bffc7b6bcb22fa15bba388721e [weak]
    - Filesize:20144902 [weak]
   Last modification reported: Tue, 03 Mar 2020 04:23:27 +0000

I have installed Docker CE using the instructions before and it worked just fine. I also tried to download the debian packages and install with dpkg -i but it says that the package is corrupted. I am able to install anything else from apt, so the network is OK.

2 Likes