Docker Community Forums

Share and learn in the Docker community.

Cannot install docker compose on raspberry pi 3

I have tried to install docker compose on my raspberry pi, so I could run a temperature logging server on it. I have tried using official documentation as guide, it doesn’t say anything, it just runs them and I can’t find docker compose afterwards. I have tried installing it on pip, but it gives me an error which I can’t find solution

Here’s the error:

compilation terminated.

Traceback (most recent call last):

  File "<string>", line 1, in <module>

  File "/tmp/pip-build-XnIvGX/pynacl/setup.py", line 255, in <module>

    "Programming Language :: Python :: 3.7",

  File "build/bdist.linux-armv7l/egg/setuptools/__init__.py", line 144, in setup

  File "build/bdist.linux-armv7l/egg/setuptools/__init__.py", line 139, in _install_setup_requires

  File "build/bdist.linux-armv7l/egg/setuptools/dist.py", line 724, in fetch_build_eggs

  File "build/bdist.linux-armv7l/egg/pkg_resources/__init__.py", line 782, in resolve

  File "build/bdist.linux-armv7l/egg/pkg_resources/__init__.py", line 1065, in best_match

  File "build/bdist.linux-armv7l/egg/pkg_resources/__init__.py", line 1077, in obtain

  File "build/bdist.linux-armv7l/egg/setuptools/dist.py", line 791, in fetch_build_egg

  File "build/bdist.linux-armv7l/egg/setuptools/command/easy_install.py", line 679, in easy_install

  File "build/bdist.linux-armv7l/egg/setuptools/command/easy_install.py", line 705, in install_item

  File "build/bdist.linux-armv7l/egg/setuptools/command/easy_install.py", line 890, in install_eggs

  File "build/bdist.linux-armv7l/egg/setuptools/command/easy_install.py", line 1158, in build_and_install

  File "build/bdist.linux-armv7l/egg/setuptools/command/easy_install.py", line 1146, in run_setup

distutils.errors.DistutilsError: Setup script exited with error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-XnIvGX/pynacl/

When using the preinstalled Ubuntu 18.04.2 for Raspberry3 with the typical installation approach curl -fsSL get.docker.com -o get-docker.sh && sh get-docker.sh the docker-compose installation seems to be fine.

unable to pull image docker.io/store/docker/engine-enterprise:18.09.4: failed to unpack image on snapshotter overlayfs: no match for platform in manifest sha256:bef18b7f2f59a0f2c459699898d1b40223c39e7e3ff811c239c860098999d44f: not found

what now?

I have no idea. I succesfully updated today from docker-ce 18.09.3 to 18.09.4.
Something seem to be messed up on your system…

What does your nippet belong too? It is definitly not releated to the docker-ce installation itself.

what nipped? I have no idea what do you mean

oh, a s is missing: snippet

how do I check that?

Where does THIS come from?

from command sh get-docker.sh

What you experience is not a generall problem. Since your keep everything except the error messages a good secret, there is NO WAY to guess where things might to wrong.

I would suggest to backup you data. Format the sdcard and flash the ubuntu 18.04.2 image on it, then use the installer. Something is wrong with your OS.