Docker Community Forums

Share and learn in the Docker community.

Cannot remove C:\DockerVolumes after "docker system prune"

A few months ago I was working on a docker project I forget what I was even doing but my VM is getting pretty full so I cleaned up all my images using prune. As I was looking through my windows explorer I noticed the folder “C:\DockerVolumes” so I tried to delete it and am getting permissions denied. So I looked up how to remove volumes and ran everything it told me to run, even though I had already pruned all my containers. Every Prune I ran showed me reclaiming 0 bytes. I can’t for the life of me delete this folder! I’ve tried everything, did a system prune, tried to shut down the dockerd.exe service. Rebooted without starting the Docker service! What is locking this folder? How do I reclaim the 10GB space this is holding?

By default, volumes are not removed to prevent important data from being deleted if there is currently no container using the volume. Use the --volumes flag when running the command to prune volumes as well: