Docker Community Forums

Share and learn in the Docker community.

Cannot run Docker properly when I switch on my PC


(Kbeaskoetxea) #1

Hi everyone,
I downloaded the Docker toolbox for Windows10 Home edition, but everytime I run a Docker command on powershell/cmd/git bash I have the same problem:

docker info

Response:

error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.35/info: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

It seems that the daemon is not working properly when I switch on my computer, so I cannot run Docker…

However, I found that if I run the ‘start.sh’ bash script it can start working (but only on my git-bash shell, cmd/powershell still have the same issue).

I would like to run Docker from Windows Powershell instead of using git-bash, so do you know guys what do I have to do? Change script content? Re-install the toolbox?

Thanks.