Docker Community Forums

Share and learn in the Docker community.

Docker not running in GitBash Windows 7 error during connect: "...daemon is not running"

Hy everyone!

I have searched for the same problem in this forum but I didn’t find anything. If I am wrong and the issue has been already open and resolved by another user I apologize in advance.

I use Windows 7 and I have installed the Docker toolbox.
The container is on GitHub (I didn’t develop it) and I have the git bash installed too.
I have tried to run very easy commands on the Docker terminal (like $docker version) and it works well,
but with the git bash, the same command gives me the version but at the end there is an error message:

Client:
Version: 1.13.1
API version: 1.26
Go version: go1.7.5
Git commit: 092cba3
Built: Wed Feb 8 08:47:51 2017
OS/Arch: windows/amd64
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.26/version: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

Any other Docker command I try to run displays the same error message.

In the Docker terminal this doesn’t happen.

Why is working on the Docker terminal and not on git bash? What should I do in order to make it work for git bash?

Maybe the issue is too simple but I am quite new to the topic so if you could redirect me to the information that will be very helpful too.

Thanks in advance

Isabel