Docker Community Forums

Share and learn in the Docker community.

Cannot Share Drive in Windows 10

The solution worked for me. thanks

This was the solution for me. Thanks a lot.

The solution No.2 worked for me. Thank you!

For Windows 10.
1)Ensure the “server” service is running

  1. Open gpedit.msc and goto Windows settings-> security settings->local policies->security options, find “Microsoft network server: Server SPN target name validation level” and set its value to “Accept if provided by client” or “OFF”.

It works for me, your 6 hours help me in just 6 minutes, thank a lot bro

Worse case scenario. The 5 second solution is run docker as Administrator in windows.

he sharing of the drive sets the permissions for “Everyone” in sharing, but the root drive doesn’t have “Everyone” included in it’s security settings, so there is a conflict. I had to add an “Everyone” to the drive root settings and bingo - suddenly the sharing worked.

I find it interesting that the drive doesn’t have an “Everyone” setting. Can anyone tell me if there is a negative aspect to setting this? There must be a reason why “Everyone” is missing from the default security settings of a drive.