Docker Community Forums

Share and learn in the Docker community.

Yet another thread for unable to share a drive in Windows 10


(Doghelmet) #1

Expected behavior

Drives can be shared in the settings interface.

Actual behavior

Docker for Windows always complains about being blocked by a firewall:

However, disabling both Windows Firewall and Kaspersky Internet Security does NOT help. But I can access all my shared folders from other computers with no problem, even if the firewall is enabled. The most weird thing is: it once worked, but never works again ever since. I tried resetting Docker for Windows, still no help.

Information

Docker for Windows 17.03.1 ce from stable channel
Windows 10 update 15063

In docker’s log file , I found things like:
[16:22:01.072][NamedPipeClient][Info ] Sending Mount(D, -PC*:, Docker.Core.Settings)…
[16:22:01.073][NamedPipeServer][Info ] Mount(D, -PC*:
, Docker.Core.Settings)
[16:22:01.073][SambaShare ][Info ] Mount D

[16:22:01.283][SambaShare ][Info ] “D” is shared
[16:22:01.285][SambaShare ][Info ] Username: ***
[16:22:01.285][SambaShare ][Info ] Host IP: 10.0.75.1
[16:22:01.285][SambaShare ][Info ] Cifs options: noperm,iocharset=utf8,nobrl,mfsymlinks,vers=3.02,domain=***-PC

[16:22:03.848][SambaShare ][Error ] Unable to mount D drive: firewall is blocking
[16:22:03.848][SambaShare ][Info ] Removing share D
[16:22:03.920][NamedPipeClient][Info ] Received response for Mount
[16:22:03.920][NamedPipeServer][Info ] Mount done in 00:00:02.8464831.
[16:22:08.523][NamedPipeClient][Info ] Sending GetDefaultVhdxPath()…
[16:22:08.525][NamedPipeClient][Info ] Received response for GetDefaultVhdxPath
[16:22:08.524][NamedPipeServer][Info ] GetDefaultVhdxPath()
[16:22:08.525][NamedPipeServer][Info ] GetDefaultVhdxPath done in 00:00:00.0009920.
(I masked the computer name and user name.)

The issue seems to be quite similar to this one: Cannot Share Drive in Windows 10
But in my case, updating Windows 10 to a new version does not solve the problem.

Steps to reproduce the behavior

Open the Docker for Windows settings interface, select any drive in the Shared Drives page, and click the Apply button.


(Michael Friis) #2

Could you run the diagnostics and open an issue here? https://github.com/docker/for-win/issues/new