Docker Community Forums

Share and learn in the Docker community.

Unable to share drives

docker

#1

Host: Windows 10 Enterprise, 64 bit, BUT I am logged in on a local admin account that appears to be completely disconnected from the workplace’s local network as far as I can tell (no network drives, printers, etc.)

Unable to share both local drives and thumbdrives.

"Firewall detected

A firewall is blocking file Sharing between Windows and the containers. See documentation for more info."

I have tried everything listed in the documentation, and a few pages of github community fixes since 2016.

github 1
github 2
github 2

So I’ve done a lot of things on the Firewall, network adapter (mostly restarting), and ports, nothing works.
Some have solved it by switching to edge version, but that was in 2017, surely those fixes would have made it into stable by now?

I’m at a loss for what else to try.

I just need to send some .py and .sh scripts into the docker, and copy-pasting straight up doesn’t work when VIM is active in the docker SSH terminal. Alternative suggestions also welcome :slight_smile:


(Tekki) #2

It’s not a Docker, it’s a firewall issue. You have to add the docker network (10.0.75.1/24) to the list of trusted networks. Can’t give you more details, you don’t tell us what product you use.


#3

That’s literally the first solution I tried, it was in the official documentation.

What do you mean by what product I use? I am on the stable release version, if that’s what you mean.


(Tekki) #4

The problem is with the firewall, so I speak about the firewall product. In Kaspersky Internet Security for example I have to go to Protection–Firewall–Networks and there set the Network Type of 10.0.75.1/24 (vEthernet (DockerNAT)) to Trusted Network. You can expect that these settings get lost with every second update.
Docker on Windows runs in Hyper-V and in the first step the drives are mounted as CIFS mounts (Windows shares) into the VM. From there the individual folders are connected to the containers.


#5

Oh. I’m not using any 3rd party firewall or antivirus, just default windows’ firewall and defender.

I’m almost 1000% sure that I’ve set the right allowances and permissions, but it did not help. With further searching, there used to be a solution where Windows Firewall can be entirely disabled for specific network adapters, e.g. the vEthernet (docker) adapter, but that ended with Win7 and does not exist anymore in Win10 (unless, perhaps through 3rd party Firewalls).

So I

  1. made sure my other network adapters are set to “Private” networks, and my vEthernet (docker) to “guest/other” networks,

  2. disabled Firewall for all “guest/other” networks, AND

  3. close docker and manually start it in Admin mode.

This finally allowed the C drive to be mounted without error messages. I will be testing if it’s fully functional shortly.

P.S. Do you guys see the “1. 2. 3.” on my ordered list? It’s just showing indents on my side.


(Tekki) #6

This sounds strange. Is your PC part of a corporate network?


(Dougis) #7

As a TEST ONLY try disabling windows firewall altogether. If that allows the share then you don’t have the correct rules in place. Turn Windows firewall back on and revisit your allow rules.