Can't compose up with the multi-container-app tutorial

I’m running through the launch multiple applications tutorial, I’ve cloned the git (⁠) and have entered the command

docker compose up -d

and I get

validating [path I made for docker tutorials]\multi-container-app\compose.yaml: services.todo-app Additional property develop is not allowed

I am using an elevated powershell, I vaguely remember ignoring a message about a deprecated command/function while doing the previous tutorials (I can’t seem to find it in my shell history so maybe i imagined it)

so I tried docker compose --compatibility up -d

No difference

Taking a look inside compose.yaml I didn’t see anything strange except for some commented lines at the end and the Dockerfile within /app I did see some linux commands and a folder structure that doesn’t match the git nor what i have

# Run the application as a non-root user.
RUN chown -R node /usr/src/app

Am I missing something? or is it that just the tutorial was intended for linux docker users?

I can’t find which version started to support the “develop” section, but you probably have an older Docker Compose version. You could upgrade your Docker Desktop to the latest version which would have the latest compose as well, or just remove the whole “develop” section from the compose file. Then when you change the source code, compose will not trigger a rebuild, but the services could start at least and you could rebuild manually any time.

Compose watch (the “develop” keyword, and its sub elements) require docker compose 2.22.0 or newer, which came bundled with Docker Desktop 4.24.

See: Announcing Docker Compose Watch GA Release | Docker

ah. I thought i had the newest version cuz I just downloaded docker. But I do see that there’s an update available. I’ll give it a try. Thanks! (and yeah the version number was showing

I’m running through the multi-container-app tutorial, and had the error:
services.todo-app Additional property develop is not allowed

I’m on Windows Docker Desktop 4.25.2. The tutorial code was directly cloned from the git repo, with no modifications. Commented out the entire develop: stanza to get the tutorial code to run. :man_shrugging:

Check your compose version as well. Maybe you just has another version of docker compose due to a failed update.

believe this is the current version - I just installed docker desktop for windows last week, so it should all be current (i.e. this is not an upgraded install)

$ docker compose version
Docker Compose version v2.23.0-desktop.1

I would expect it to work, but I’m not really sure if this feature is supported on Windows as well. I tried only on macOS, but I couldn’t find anything in the docs about this feature not working on Windows. Have you tried search for similar issues on GitHub?