Docker Community Forums

Share and learn in the Docker community.

Can't create default vm on docker beta for mac


(Jdmr) #1

After installing docker beta for mac, whenever I tried docker ps command it would just hang (not respond, the computer kept on working). So decided to just delete the vm, but now that I’m trying to create the vm there’s no driver other than the virtualbox one. How am I supposed to create my default local vm on the docker beta for mac environment?

I tried docker-machine create -d xhyve default and got
Driver “xhyve” not found. Do you have the plugin binary accessible in your PATH?

Do I need to install the xhyve driver from https://github.com/zchee/docker-machine-driver-xhyve?


(Rohinton Kazak) #2

What version of OSX are you running? Also have you read the FAQ as this
may have relevant information?
https://beta.docker.com/docs/mac/faqs/


(Jdmr) #3

I’m using 10.11.5… But I figured it out, it so happens I had previously installed docker before the toolbox came out and had some environment variables that made docker commands misbehave, removed that environment variables and everything works.

Thanks…


(Juliusbachnick) #4

Did you need to install https://github.com/zchee/docker-machine-driver-xhyve beforehand or did it just work out of the box (I had to install the driver using brew before and was wondering whether that would be necessary).


(Jdmr) #5

I did a re-install and it just worked.


(Rohinton Kazak) #6

You should not need to install any additional items, unless directed by the
docker 4 mac team.