Can't get Docker Beta to work

I actually ended up having to uninstall the Docker for Windows beta. Without network access I was dead in the water. I found this thread but all the suggestions broke communication with the VM (i.e. the problem I had before).

1 Like

I’m sad to hear that you uninstall the product :frowning: If you decide to give it a change another time, please let us know, so we can figure it out how to solve it.

Well I’d love to help resolve it but today I had to do some docker stuff for work so I just needed to get up and running and I was out of things to try. I’ll reinstall very soon.

Hi Docker folks

Just downloaded and installed D4W. Super easy install. All went as expected. I ran into essentially the same issue as others here. It wasn’t obvious what IP address to use to connect to the container. We happened to figure it out based on the error message that was shown when we tried to run docker info while the VM wasn’t running and we got the error: Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party
did not properly respond after a period of time, or established connection failed because connected host has failed to r
espond.
That was the only way that we knew what the IP address was. Then I see on the forum here that you can see the IP address if you select the VM in the Hyper-V Manager and then select the Network tab in the bottom pane. It’s pretty obscure. Without docker-machine ip I was a bit lost trying to find the IP address.
It would be great if you guys could improve the discoverability of the IP address. Maybe a docker ip command or make it part of docker info or something.
Thanks!

To connect to containers that are running services, you can use the docker hostname. Eg. http://docker:5000/ for a HTTP service that exposes port 5000. See the getting started doc for details.

Does that work for you?

We know that the transition from docker-machine can be a bit abrupt. We’re working on catching the worst pitfalls, but would also love your ideas for how this could be made more obvious.

Michael

Just going through the process on the Mac now and I see in the docs there that you can run ping docker.local to get the IP address of the container. I tried this on Windows and it resolved at first to the IPv6 address. Running ping -4 docker.local shows the IPv4 address. It would be useful to add that to the Windows version of the documentation.

@radtravis Out of curiosity, why do you want the IP address? Is the docker (or docker.local) hostname not working for you?

The name resolution is different on Mac and Windows. On Mac we currently use mDNS (hence the .local suffix). mDNS is not available out of the box on windows and we use LLMNR (the native windows protocol) instead. LLMNR seems to have a habit to prefer IPv6 and also the windows name resolution has a habit of dropping the mDNS reserved .local suffix and perform an LLMNR lookup instead.

We are aware of these issue and are currently investigating unifying the naming on both platforms.

1 Like

All of this note is in the context of D4W…

Thanks for the update rneugeba. That explains things a bit. Michael - I did try connecting with all of the following:
docker.local:1433
docker:1433
docker.local
docker

None of those works but the IP address works fine.

I would be surprised if docker or docker.local would ever work on Windows because typically Windows looks for a DNS name resolution first for something like ‘docker’ unless you had something in the lmhosts file that mapped ‘docker’ to a local IP address.

Side note: localhost also does not resolve so apparently port forwarding is not working as expected.

I also can’t connect to the public IP address of the host and have it port forward to the guest container. Is that supposed to be working yet?

I think the critical problem for me was the opposite. For me it was OUTBOUND communication from the vm that wouldn’t work. That’s a showstopper if you can’t even pull down an external base image or anything else your container might need.

@taschmidt we’ve seen that with others. Did exiting the Docker app and starting it again not get it online?

Nope, I tried rebooting, having it recreate the vm, nothing worked. I saw some threads where people were having troubles with wifi connections and hyper-v, which I have, but I haven’t been able to try a wired connection yet.

For those having this kind of connectivity problems after upgrade / reinstallation of the beta, I’ve posted a possible solution here: Docker commands not working after upgrade

I created a new topic here to track the issue I’m having now with no external network access.

Dear Michael,

please can you give some more information about what the difference is regarding docker-machine. Is not possible to create multiple docker-machines and why? I am researching on Docker for Windows and it would really help me if you could explain a bit more. I red somewhere that Docker for windows archives isolation between containers by running each container on a separate VirtualMachine. Is that the case? Thank you very much in advance!