Docker Community Forums

Share and learn in the Docker community.

Docker commands not working after upgrade


(Chribben) #1

Expected behavior

List docker containers

Actual behavior

Error (see below)

Information

Output from docker ps
Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Steps to reproduce the behavior

  1. Upgrade Docker for Windows to version 1.10.6.958 (Beta)
  2. Run docker ps

(Boris Böhne) #2

Same for me. First beta worked fine, upgrade to 1.10.6.958 breaks connectivity.


(Boris Böhne) #3

I’ve managed to get it working again using the following steps:

  1. Uninstalling Docker
  2. Removing the Docker VM in the Windows Hyper-V Manager
  3. Reinstalling Docker using a freshly downloaded copy of the beta

I think key was the second step: after uninstalling Docker, the VM still remains in Hyper-V manager.


Can't get Docker Beta to work
(Chribben) #4

Seems as if the MobyLinuxVM is unable to obtain an IP-address after upgrade.
(Get-VMNetworkAdapter -VMName MobyLinuxVM).IPAddresses returns empty.


(Stefan Scherer) #5

I can reproduce the problem. First time it worked with “Beta-5” 1.10.6.958 as I’ve installed it into a fresh Win10 VM.
But installing 1.10.6.852 and then updating it to 958 the problem is that the engine is not responding.

I had to reboot after the update as some files have to be overwritten.

Are there any logfiles you need out of my VM?


(Chribben) #6

Just realized this is a duplicate, see here.
Workaround is to uninstall version 1.10.6.852 (Beta 4), download the latest version from the download page and install it.


(Chribben) #7

I wanted to try out something with Docker Toolbox so I turned off Hyper-V, installed Docker Toolbox and did some testing.
Then I switched back to D4W and uninstalled Docker Toolbox. Now Docker can’t connect to the VM with neither Beta 4 or Beta 5!
The VM is assigned an IP-address (10.0.75.2) but pinging it times out. Very frustrating :disappointed:


(Chribben) #8

Ended up doing a total reset of my machine and after installing Docker for Windows again it now works.


(Michael Friis) #9

@chribben @stefanscherer thanks for the detailed problem report. I’ve created an issue to track problems with upgrades. In the interim, un-installing and installing from scratch is a good workaround.

Sorry about the breakage.