Can't reach

I have a docker file, that worked yesterday, but now I’m running into a problem. The problem seems to be with the connectivity of

=> ERROR [internal] load metadata for                                                               30.0s
 > [internal] load metadata for
   1 | >>> FROM gcc:12.1.0-bullseye
   2 |     
   3 |     RUN git clone --depth 1 --branch v3.23.3 && \
ERROR: failed to solve: DeadlineExceeded: DeadlineExceeded: DeadlineExceeded: gcc:12.1.0-bullseye: failed to do request: Head "": dial tcp i/o timeout

Is there something I can do about this, or I just have to wait till the service is up again?

kind regards,


1 Like

Hello Torsten,

I’m sorry to hear that you’re facing issues with your Dockerfile. The error message you’re seeing suggests that there’s a connectivity issue with the Docker registry at the moment. It’s possible that the registry is currently down or experiencing high traffic, which could cause a timeout.

Before taking any further steps, I’d recommend checking the status of the Docker registry to see if there are any known issues or scheduled maintenance. You can do this by visiting the Docker status page at

If there are no known issues, you can try the following troubleshooting steps:

  1. Check your internet connection to ensure that you’re not experiencing any connectivity issues.
  2. Try running the docker build command with the --no-cache option to ensure that you’re not using any cached images that may be causing issues.
  3. Try using a different Docker registry mirror to see if that resolves the issue. You can set a different registry mirror by adding the --registry-mirror flag followed by the URL of the mirror you want to use.

If none of these steps work, then it’s possible that the issue is with the Docker registry itself, and you may need to wait for it to come back online. In the meantime, you could try building your Docker image using a different base image or a different version of the same base image.

I hope this helps.

1 Like

Hi Eden,
thank you for the response. Two days later, the problem was gone. I don’t think that was unavailable to all users over that time. I guess, I would have read about it somewhere, if larger parts of the world would have been unable to build docker containers. On the other hand, I did not recognized any other internet connection issues. The build process of one of my software products rely on docker and I feel pretty bad about the chance, that parts of the build fail to work due to issues like this for so long.

Where could I see a list of mirrors, that I could use, if that issue happens again?

Thank you very much!

I have the same issue with my server connection. It’s weird somethins it works. I think it’s related to my IAS provider OVH. I have timeout when I tried to download a docker image or even with a telnent.
docker pull jenkins/ssh-agent
Using default tag: latest
Error response from daemon: Get “”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)