Can't run a docker container

hi to docker community :
i installed parrotsec on Vmware , and installed also docker in parrotsec using “sudo apt-get install” and updated everything .

unfortunetly after installing a container called using docker pull hello-world , i see it in the docker images but when i tried to start it ,i get the following errors :

Error response from daemon: No such container: hello-world
Error: failed to start containers: hello-world

i tried different solutions on internet but no one worked.

here are my linux specifications are :
PRETTY_NAME=“Parrot OS 5.0 (Electro Ara)”
NAME=“Parrot OS”
VERSION=“5.0 (Electro Ara)”

Parrotsec is not a supported operating system, so can you share where you found the instructions to install Docker? the package is not from the official repository provided by Docker.

Since Parrotsec is based on Debian, maybe you can use the instructions written for Debian:

Of course that is not guaranteed to work either. If there is a Parrotsec community, they could give you more help with the Parrotsec specific issues and give you a working installation guide.

Well, the internet is huge. Can you share exactly what you tried so nobody will spend time on searching for solutions that you have already tried?