Docker Community Forums

Share and learn in the Docker community.

Can't start docker beta: Communication with networking components failed


(Blubber) #21

Yes I have the VPN setting problem as well. If you uncheck it and look at the logs it doe reboot the VM, but I’m not sure if the setting is actually toggled off after the reboot as the debug info is somewhat sparse. And indeed, reopening the settings dialog resets the setting.

I also tried setting it via pinata pinata set network nat with the same result (I’m guessing the settings dialog is calling pinata with the same arguments.)

(Tim Haak) #22

Seem to be the same errror as

Possibly easier to put any findings their so it’s all in one place.

(Blubber) #23

The latest update seems to have solved my problem, although I haven’t rebooted yet. The only thing that is currently not working is docker.local.

(Mxbence) #24

Today I installed the beta for the first time, and had the same error. This chmod fixed it tho.
Thanks @synic!

(Synic) #25

This is still an issue, with every release.

(Adrien Duermael) #26

We could reproduce the issue on a Mac.
I think we can try to fix the symptoms in the next beta.
But I still don’t know what causes this…

(Adrien Duermael) #27

When you had to chmod 600, do you know what was the ownership before you did?
It worked just fine for me with 644 when I got the issue. (I didn’t have to chmod anything)

(Synic) #28

Looks like 664:

-rw-rw-r-- 1 root wheel 688 May 26 08:23 com.docker.vmnetd.plist

If I change it to 644, it works, as well as 600. 664 does NOT work.

(Adrien Duermael) #29

Yes, rights can’t be too elevated.
I thought what we’re calling to register the vmnetd took care of setting correct ownership.
We’ll enforce it.

(Longkt90) #30

This fix work for me

(August Kleimo) #31

Big thumbs up. This also worked for me.