Docker Community Forums

Share and learn in the Docker community.

Can't start docker beta: Communication with networking components failed


(Synic) #1

Expected behavior

Installation completes

Actual behavior

I get the message “Communication with networking components failed.” Logs:

2016-04-06T11:36:16.155413-06 Info - Application version: 1.11.0-beta6 (5404)
2016-04-06T11:36:16.177220-06 Info - OSX Version: Version 10.11.4 (Build 15E65)
2016-04-06T11:36:16.434267-06 Info - migrator: start migration process
2016-04-06T11:36:16.436028-06 Info - migrator: previous install detected
2016-04-06T11:36:16.436114-06 Info - migrator: previous version is 1.11.0-beta6
2016-04-06T11:36:16.436173-06 Info - migrator: no migration needed, you are good to go!
2016-04-06T11:36:16.436226-06 Info - migrator: end of migration process
2016-04-06T11:36:16.462726-06 Info - event tracker initialized
2016-04-06T11:36:16.465117-06 Info - Limited access: checking…
2016-04-06T11:36:16.548575-06 Info - Bundle path: /Applications/
2016-04-06T11:36:20.536796-06 Info - privileged installation of com.docker.vmnetd successful
2016-04-06T11:36:20.536925-06 Critical - Communication with networking components failed.


Where does one get pinata?

I am running OS X 10.11.4 on an early 2015 macbook pro. I have uninstalled virtualbox just to make sure.

Steps to reproduce the behavior

  1. Open for the first time

(Synic) #2

I sort of got pinata working… ish. I had to run docker-diagnose manually.

[bin]$ sudo ./docker-diagnose
OS X: version 10.11.4 (build: 15E65) version v1.11.0-beta6
Running diagnostic tests:
[ERROR] docker-cli cannot find docker
[ERROR] Moby booted /Users/synic/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[ERROR] driver.amd64-linux /tmp/fs.socket does not exist
[ERROR] vmnetd /var/tmp/com.docker.vmnetd.socket does not exist
[ERROR] osxfs /var/tmp/com.docker.osxfs.socket does not exist
[ERROR] db /var/tmp/com.docker.db.socket does not exist
[ERROR] slirp /var/tmp/com.docker.slirp.port.socket does not exist
[OK] menubar
[OK] environment
[ERROR] Docker Docker is not running
[OK] VT-x
docker-diagnose: internal error, uncaught exception:
Sys_error("/Users/synic/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/log: No such file or directory")

(Tristan O'Neil) #3

I also ran into this same issue, here are my logs.

2016-04-06T20:17:22.520189-04 Info - Application version: 1.11.0-beta6 (5404)
2016-04-06T20:17:22.538529-04 Info - OSX Version: Version 10.11.4 (Build 15E65)
2016-04-06T20:17:22.794001-04 Info - migrator: start migration process
2016-04-06T20:17:22.799272-04 Info - migrator: previous install detected
2016-04-06T20:17:22.799319-04 Info - migrator: previous version is 1.11.0-beta6
2016-04-06T20:17:22.799345-04 Info - migrator: no migration needed, you are good to go!
2016-04-06T20:17:22.799367-04 Info - migrator: end of migration process
2016-04-06T20:17:22.817283-04 Info - event tracker initialized
2016-04-06T20:17:22.820893-04 Info - Limited access: checking…
2016-04-06T20:17:22.887122-04 Info - Limited access: wrong certificate. Asking user for token
2016-04-06T20:17:28.542152-04 Info - text changed
2016-04-06T20:17:28.953648-04 Info - Entered token: wwB6F2agrJGZm4ebSnPHOrxsn
2016-04-06T20:17:32.631413-04 Info - Bundle path: /Applications/
2016-04-06T20:17:35.803680-04 Info - privileged installation of com.docker.vmnetd successful
2016-04-06T20:17:35.803795-04 Critical - Communication with networking components failed.
2016-04-06T20:17:54.550096-04 Info - Tried to stop WatchDog but it was not running
2016-04-06T20:17:54.554220-04 Info - applicationWillTerminate

(Synic) #4


Did you happen to use dlite before?

(Tristan O'Neil) #5

Yes I have. Do you have a fix?

(Synic) #6

Nope, just trying to figure it out.

I wonder if it’s something dlite changes or installs, etc.

(Synic) #7

More debugging info:

[~]$ sudo /Applications/
Apr 6 19:08:15 com.docker.vmnetd[2362] : com.docker.vmnetd starting
Apr 6 19:08:15 com.docker.vmnetd[2362] : Failed to launch_activate_socket: Undefined error: 0

(Elson Wu) #8

My Docker does not work for the first time after installed, I have to restart my Mac, then it works fine without problem, maybe you should try.

(Spants) #9

Exactly the same here after the update. I had to restart my mac.

(Synic) #10

Unfortunately, it did not help for me to reboot

(Synic) #11


Figured it out, the fix is:

$ chmod 600 /Library/LaunchDaemons/com.docker.vmnetd.plist
$ sudo launchctl load -Fw /Library/LaunchDaemons/com.docker.vmnetd.plist

Then try starting again.

(Sunjs) #12

Same here
Apr 6 22:32:24 com.docker.vmnetd[4800] : com.docker.vmnetd starting
Apr 6 22:32:24 com.docker.vmnetd[4800] : Failed to launch_activate_socket: Undefined error: 0

(Blubber) #13

Having the exact same issue here. It worked right after installation then after a reboot it started getting flaky, now it’s not working anymore at all. I get the same vmnet errors, but I can run containers as usual. Only when I expose ports and use docker ps it says that the port maps from none:5000->5000.

(Synic) #14

This appears to still be broken in the latest beta. It just installs that file with the wrong permissions every time.

(Blubber) #15

The permissions do not seem to be the problem though, I tried chmodding it to 0600 but it still reports the same error, and my container still don’t have network access.

I’m now thinking it might have something to do with my VPN software (Tunnelblick), it has created two additional interfaces, perhaps it is confusing Docker.

(Synic) #16

You need to launchctl load after

(Blubber) #17

In your earlier post you load the plist after chmodding it. You cannot load units into launchd that are already loaded, the fact that you are not getting an error seems to indicate that the unit wasn’t loaded in the first place, and that the load fixed the problem, not the chmod.

Having said that, I tried unloading, chmodding and loading the unit again, also tried stopping and starting the daemon, and indeed, the mac itself. It doesn’t work.

(Synic) #18

I actually found the permission error by using launchctl. Running it on a plist that has the incorrect permissions will give you an error. So, yes, loading it does fix it, but you can’t load it when it has the wrong permissions.

Sorry it’s not working out for you - what mac do you have?

(Blubber) #19

It’s a macbook air from 2013. I had Docker for Mac working, kind of, it had the huge lag when resolving docker.local, but it worked. Then I rebooted and it stopped working, then I rebooted again, and it worked again :). But after a while and a couple reboots it stopped working permanently.

My guess is that my VPN software (Tunnelblick) is interfering.

(Paolo D.) #20

Same problem here, as described from the others:
vmnet does not start, i don’t get the ip from docker mac.

I had dlite installed.

chmod does not fix anything.

One thing i noticed is that i cannot remove from the settings the vpn experimental feature.
If i uncheck the box and reopen the settings is back there…