Docker Community Forums

Share and learn in the Docker community.

Can't view web server ports nor ssh to container


(Wyatt Frelot) #1

Good afternoon,

I am a beginner to docker and I have worked through the beginner tutorials and I am totally stuck and have been unsuccesful in being able to view web server ports on container and successfully ssh’ing into a container: These are the ports that I have exposed:

NAMES
99de20912b06 ruo91/hadoop “/usr/bin/supervisord” 2 hours ago Up 2 hours 0.0.0.0:8042->8042/tcp, 0.0.0.0:8088->8088/tcp, 0.0.0.0:50070->50070/tcp, 0.0.0.0:50075->50075/tcp, 22/tcp, 0.0.0.0:50090->50090/tcp hadoop

I cannot ssh into the container, although I have been able to assign an IP Address:
hostnode:docker-hadoop wyatt.frelot$ docker inspect --format ‘{{ .NetworkSettings.IPAddress }}’ 99de20912b06
172.17.0.2

Any help would be greatly appreciated! Thanks!


(Ranjandas) #2

Hi,

Does your docker container have SSH server running inside?. Also , where are you running container? On boot2docker?

Regards


(Wyatt Frelot) #3

Ranjandas,

Thank you for the reply. To answer your question ssh server installed. I guess I am not sure if it is ssh server or client. I do know ssh is installed! However I am not certain if it is ssh -server or something else. Outside of this hadoop container that I have used, I ran into a similar problem with the training/webapp container provided for initial instruction when going through the documentation.

Secondly, I am running the container on OSX using the “default” docker load out (not “boot2docker”) when it is installed on OSX for the first time.

Hopefully this provides enough information for you to respond. In the meantime, I will work on ensuring I verify ssh-server is installed.

Wyatt