Docker Community Forums

Share and learn in the Docker community.

Chrome on Neon:user in Docker on Kubuntu 20.10

I am unable to get the latest stable version(s) of Chrome to run properly on Neon in Docker on Kubuntu 20.10. I’m using Xephyr and my run command is “docker run -v /tmp/.X11-unix/X1:/tmp/.X11-unix/X1:rw -e DISPLAY=:1 neon:rev(X)”. I have tried starting Chrome with and without the -no-sandbox option, and invoking with user and root, no joy.

Chrome crashes with various error messages, including “ERROR:nacl_helper_linux.cc(308)] NaCl helper process running without a sandbox! Most likely you need to configure your SUID sandbox correctly”, “aw Snap something went wrong”, or the Chrome window simply disappears.

I have also tried Chromium downloaded from Google, but Google recently discontinued support for the “sync” feature for the Chromium open source version, which is important to me. (Note Firefox works but obviously doesn’t sync with Google either, and installing chromium from Neon repositories leads to the message “chromium browser requires chromium snap to be installed with “snap install chromium””, and I can’t get snap working either).

Unfortunately I don’t have a clue how to “configure your (my) SUID sandbox correctly”. I’m wondering if Chrome is working for others with setups similar to mine, and what they did to get it working; and/or what logs I should enable and review to perform further diagnosis.

Thx, Gus