Com.docker.hyperkit up CPU to 340%

when i run
npm install from the node container process
com.docker.hyperkit up CPU to 340%

Hi, same here.

After npm install is completed, CPU usage stays around 200% for com.docker.hyperkit.

+1 Same here. I’m using godo to hot reload my golang app and it’s sooooo slow.

Oh oh guys very bad sometimes I see IO ERROR WHEN NPM try download and install I think it can be problem with sharing fs from host to container

I’m seeing this as well. Going to try a full rebuild. It seems tearing down the containers brings the cpu usage back down which is good.

EDIT: yeah. CPU usage is off the charts in general even compared to my old setup with dinghy and VirtualBox. My test suite ran in 3min20sec on docker for mac and only takes 20sec on VirtualBox.

I have no container running with Docker version 1.11.1, build 5604cbe and com.docker.hyperkit takes between 150-200 % cpu… I think something wrong…

Here are the logs:

For me it stop after restarting docker until my laptop get awake after sleep.

I am hitting the same behavior.

I restart, it picks up again right away.

Eventually it stops.

Grabbed a thread-dump while it was spiked:

Tried to stop Docker, then ran it again: same issue.
Tried to rebuild all images and containers: same issue.

My containers are built using docker-compose. I didn’t have this issue with Docker Toolbox.

Below are more info about my mac.

I’ve seen this as well

I revert prev docker version with VBox bcs my product projects die and i can’t hope docket team will fix it and i can try again.

I’m seeing the same issue right now. The machine was just brought out of sleep mode, the com.docker.hyperkit process spiked all the way to 190-200% and com.docker.osxfs remained at 20-30%. There are no containers running.

My trace, in case it helps:

1 Like

+1 on seeing this issue.

Just want to confirm that I’m seeing the same behavior as @oscarrrenalias. Machine coming out of sleep mode and no containers running.

Also seeing heavy CPU load (around 180%) with com.docker.hyperkit as well as with com.docker.osxfs (around 75%) - all when coming out of sleep for docker for mac. Restarting docker seems fine. (Version 1.11.1-beta13 (build: 7975)).

OSX El Capitan (v 10.11.5):
Model Name: MacBook Pro
Model Identifier: MacBookPro11,3
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB

+1. Same here. It happen after my macbook wake up from hibernation. And my docker process is gone as well. my docker process is rabbitmq.

1 Like

+1 I get it with OSX 10.11.5, Docker 1.11.1 beta 3

Same problem here

Version 1.11.1-beta13.1 (build: 8193)

com.docker.hyperkit 130%
com.docker.osxfs 50%

OS X 10.11.5
Model Name: MacBook Pro
Model Identifier: MacBookPro11,3
Processor Name: Intel Core i7
Processor Speed: 2,8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB


I was using nodemon --legacy-watch Docker beta doesn’t need this flag because the com.docker.osxfs layer can watch the OS fs events.

After I removed the flag everything went back to normal


Hi all,

Same situation here. I’m running 9 containers, 7 of which run a JavaScript (Node) service.

The JS projects run in “development” mode, which in our case means that we use filesystem monitoring to re-build the project whenever a file change is detected. Gulp (implicitly) depends on graceful-fs [1]. The reason I mention it is because I suspect it’s related. Graceful-fs currently runs in an older version then needed (

I’ve included two samples, if that’s useful, of both com.docker.hyperkit [2] and com.docker.osxfs [3]. However I’m unable to upload them (being a new user and all) so I’ve included them as links.

My macOS Docker beta version 1.11.2-beta15 (build: 9168) 603884f1679ff0528724854e9d27fc8e67fdfd8f

[1] Graceful-fs - A low-level library that normalises fs calls and tries to be resilient (
[2] com.docker.hyperkit-sample.txt -
[3] com.docker.osxfs-sample.txt -

Same here. with com.docker.hyperkit and com.docker.osxfs

Running docker Version 1.12.0-rc2-beta16 (build: 9493)
OSX El Capitan 10.11.4
Running 6 containers with compose
Same instances not producing this load when used on ubuntu.

Same here.
I have 3 containers 1 for redis 1 fore mysql and 1 for rails
Docker version: 1.12.0-rc2-beta16 (build: 9493)