Docker Community Forums

Share and learn in the Docker community.

Com.docker.service will not start

The Docker Desktop Service will not run.
Using Windows 10 Enterprise 10.0.18362.
Installed Docker Desktop 2.2.0.42716.
Event Viewer has the following information:
Faulting application name: com.docker.service, version: 2.2.0.42716, time stamp: 0x8395d74e
Faulting module name: ntdll.dll, version: 10.0.18362.657, time stamp: 0x64d10ee0
Exception code: 0xc0000005
Fault offset: 0x000000000001e6a6
Faulting process id: 0x63f4
Faulting application start time: 0x01d5e73d1d337b23
Faulting application path: C:\Program Files\Docker\Docker\com.docker.service
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: c0de912b-2a12-42b8-a5c0-67758f19f8d4
Faulting package full name:
Faulting package-relative application ID:

Docker version produces:
C:\WINDOWS\system32>docker version
Client: Docker Engine - Community
Version: 19.03.5
API version: 1.40
Go version: go1.12.12
Git commit: 633a0ea
Built: Wed Nov 13 07:22:37 2019
OS/Arch: windows/amd64
Experimental: false
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.40/version: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

Tried to uninstall (so that I can reinstall) and it fails with a similar access violation:
Faulting application name: Docker Desktop Installer.exe, version: 2.2.0.42716, time stamp: 0x5e41b886
Faulting module name: sysfer.dll, version: 14.2.5078.2000, time stamp: 0x5d48ecce
Exception code: 0xc0000005
Fault offset: 0x000000000001c79a
Faulting process id: 0x597c
Faulting application start time: 0x01d5e76547de9f67
Faulting application path: C:\Program Files\Docker\Docker\Docker Desktop Installer.exe
Faulting module path: C:\WINDOWS\System32\sysfer.dll
Report Id: 770c0d91-0f67-412e-8251-556aef92d626
Faulting package full name:
Faulting package-relative application ID:

Is there logs from the OnStart of the service that I can examine? Any information to debug the problem?

I too have the same issue. Any help is greatly appreciated. Thanks.

I have not received any responses yet and have been working on different project until I hear something. Are you able to uninstall and reinstall (that was a suggestion)? I was not able to uninstall though. Thanks for replying. At least my post moved to the top.

I uninstalled and installed Docker desktop with stable and edge channels, both have the same issue. I also tried installing a previous version and the installation never completed even after 30 min. So I’m really stuck with this.

What version of Windows? I am using Windows 10 Enterprise 10.0.18362.