Docker Community Forums

Share and learn in the Docker community.

Configure the kubelet maxPods (max-pods) for docker for desktop

Does anyone knows if we can configure the kubelet maxPods for docker desktop?

I have tried this: https://kubernetes.io/docs/tasks/administer-cluster/reconfigure-kubelet/#generate-the-configuration-file, however it seems that the dynamic kubelet reconfiguration feature flag seems disabled (even if starting from v1.11 it is supposed to be enabled by default)/

I am currently using edge version community 2.0.5.0 (35318)

Thank you

1 Like

Serge,
sorry I don’t have the answer but the same question.
Do you have a solution in the meantime?
Thanks, Martin.

Minikube creates a Virtual Machine that includes Kubernetes and a Docker daemon. When Kubernetes attempts to schedule containers using Docker, the Docker daemon may require external network access to pull containers.

If you are behind an HTTP proxy, you may need to supply Docker with the proxy settings. To do this, pass the required environment variables as flags during minikube start.

For example:

minikube start --docker-env http_proxy=http://$YOURPROXY:PORT
–docker-env https_proxy=https://$YOURPROXY:PORT
If your Virtual Machine address is 192.168.99.100, then chances are your proxy settings will prevent kubectl from directly reaching it. To by-pass proxy configuration for this IP address, you should modify your no_proxy settings. You can do so with:

export no_proxy=no_proxy,(minikube ip)