Docker Community Forums

Share and learn in the Docker community.

Configured logging driver does not support reading

I keep receiving this error from docker running on a Ubuntu 14.04 server, whenever I try

$docker logs containerID
Error response from daemon: configured logging driver does not support reading

docker info produces the following:

height=“469”>Server Version: 17.05.0-ce
Storage Driver: aufs
_ Root Dir: /var/lib/docker/aufs_
_ Backing Filesystem: extfs_
_ Dirs: 131_
_ Dirperm1 Supported: false_
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins: _
_ Volume: local

_ Network: bridge host macvlan null overlay_
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
init version: 949e6fa
Security Options:
_ apparmor_
Kernel Version: 3.13.0-117-generic
Operating System: Ubuntu 14.04.5 LTS
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 7.797GiB
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Live Restore Enabled: false

WARNING: No swap limit support

When I inspect and image I get the following:
"LogPath": “”,

Does anyone know how to resolve this?
Thank you for your help.

Did you change the logging driver recently? The default is json-file. that is what you are using.
Its weird that Logpath is empty. Can you check Logconfig in the “docker inspect” for container.
Worstcase, try restarting the daemon and see if it helps.

We use shell scripts to launch the containers and one of the options sourced from a different file was passing a log option.

–log-opt awslogs-stream

This seems to be the reason the logs are unreadable.
Thanks for having a look. If I can get the logs readable, I’ll post here to help anyone else using AWS.

Thanks again.

If you go to the AWS CloudWatch console you can view the logs (that is where awslogs-stream get logged to).

Hey @shanekal, were you able to make the logs readable? If so, how did you do that?

Hope this will help.

When I ran docker info, the logging driver was json-file. However, when I ran docker inspect <container id>, the LogConfig was not set up and the LogPath was blank.

To fix the issue, I changed the logConfiguration in the task definition and restarted the service. This was the configuration I used:

"logConfiguration": {
    "logDriver": "json-file",
    "options": null

The following pages may be helpful:

1 Like

Has anyone solved this problem? I’m running into the same issue when I use Splunk Logging driver

1 Like