Confirm FIPS mode?

Hi all,

I have an Ubuntu Pro 20.04 in FIPS mode in Azure. I have installed Docker 19.03.14 on the system and it seems to work, but I cannot seem to confirm if it’s running in FIPS mode. When I run “docker info” I see no mention of FIPS. Do I have to do anything to get it to run in FIPS mode?

I tried adding “fips”: true to /var/docker/daemon.json, but Docker does not even start with this configuration.

All existing docs I can find seem to reference Docker EE which no longer seems to exist.


This indeed was an exclusive feature for Docker Enterprise, which is owned by Mirantis since 2019 and renamed to “Mirantis Kubernetes Engine”.

There is no config option for that in daemon.json and not when dockerd is started from the cli.

1 Like

Thanks for the response. Looks like I’ve gotta go look at Mirantis.