Consistent TLS Handshake Timeout When Trying to Install Portainer

I just got the parts to set up my first home server so I know maybe this is something basic for other people but not for me. I’m using Ubuntu 22.04.3 LTS and it’s a fresh install. Every time I try to run the command to install Portainer it says:

Unable to find image 'portainer/portainer-ce:latest' locally
docker: Error response from daemon: Get "https://registry-1.docker.io/v2/": net/http: TLS handshake timeout.

I’ve looked at the documentation many times and I’ve tried the centos install method that’s listed in the documentation and that doesn’t work for me either. I’ve tried looking online for other people with the same issue but some of theirs referred to files that do not exist in my installation (I have a feeling this is a previous version thing) or in relation to a poor internet connection which I don’t feel like is happening here since I did a speedtest and it came up with 60MB/s download (though it did have a poor upload speed but I doubt that’s relevant). I’m on docker version 24.0.7 if that helps.

Is it only portainer? Have you tried other images?

I tried doing another test one with homer using docker pull mgibio/homer like it says on its docker hub page but it gave me the same error. I clicked on the link that comes with the error and it says “UNAUTHORISED” and “authentication needed” so maybe that’s a lead. I try logging in through the app and it doesn’t work so I tried it in the terminal and it gives me the same error. I don’t know where to go from here, I don’t know how to fix this.

Do you need a proxy to access the Internet? Which needs authentication?

The image you tried seems to be publicly available, but note it’s already 3 years old, so be aware of potential unfixed security issues.

Not as far as I’m aware but I’d assume a proxy is something that you’d set up yourself. As for homer I’m not concerned since that was just something to check it wasn’t the portainer image specifically.
However things seem to have solved themselves. I’m sorry if anyone comes here with the same problem because I didn’t even turn off or reboot my system since then and it just decided to work so I don’t know. Maybe you should start believing in a god, any god. I believe in my cats.

Is there a way of marking this post as solved?

Not in the Docker Hub category, but the issue wasn’t really solved, it just disappeared :slight_smile: