Docker-machine error timeout

Howdy All,

I am having trouble with docker-machine now, it worked ok previously, as it timeouts for commands on machines running docker in Digital Ocean.

I can SSH to the machine fine and Docker Swarm and our system seems to be running ok on the machines (docker node command seem to work ok, e.g. docker node ls).

The problem seems just to be with docker machine. I had something similar in the past and it could be fixe by increasing the timeout but now that doesn’t help.

The error seems to be caused by a net/http HTLS handshake time out as the output from:

docker-machine ls --timeout 30


default - virtualbox Stopped Unknown
dev-m0 - digitalocean Error Unknown Get net/http: TLS handshake timeout
dev-w1 - digitalocean Error Unknown Get net/http: TLS handshake timeout
… repeated for all managers and workers.

I am running Docker CE version 17.05.0-ce-rc1-mac8 Edge on my Mac and 17.03.0-ce on the Linux machines on Digital Ocean (it seems the latest available for them). I have swapped between Edge and Stable on the Mac to see if that was causing the problem but it didn’t help.

I have restarted the machines (stop and start). I haven’t regenerated certs because I can SSH into the machines with docker-machine ssh dev-m1 without a problem, so it didn’t seem like certificates would be the problem to me. I am not trying to run any containers locally.

This has all been working fine in the past but just stopped recently.

Any help or suggestions most appreciated.


1 Like

Any ideas please why we are getting TLS handshake timeout? It used to work, I can still SSH with docker-machine into the machines so it doesn’t seem like it is a certificate issue. Docker version on client and machines may be a bit different…

I had this exact issue 2.5 years after OP! For anyone with the same problem, I finally fixed it by running crlrefresh rp on my local machine (thanks, Stack Exchange). I guess there was some discrepancy between DO’s certificate, and what my Mac thought it should be, so purging and rebuilding the cache fixed it.

Hope this helps someone!

Many thanks for that complete information! My Prepaid Center