Docker Community Forums

Share and learn in the Docker community.

Containers not runniung


(Tesdalld) #1

I am trying to run windows containers on a Windows Server 2016 VM. I have installed docker for windows and it is up and working. I am able to run commands:

docker info
Containers: 12
Running: 0
Paused: 0
Stopped: 12
Images: 1
Server Version: 17.09.0-ce
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: ics l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd json-file logentries splunk syslog
Swarm: inactive
Default Isolation: process
Kernel Version: 10.0 14393 (14393.1593.amd64fre.rs1_release.170731-1934)
Operating System: Windows Server 2016 Standard
OSType: windows
Architecture: x86_64
CPUs: 8
Total Memory: 7.999GiB
Name: TESTCONTAINER
ID: 63KJ:EH4N:6LDW:7NZL:K7B4:Z7VE:KNFQ:ERFE:GFBY:3VA6:33SV:PJ5S
Docker Root Dir: C:\ProgramData\Docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: -1
Goroutines: 34
System Time: 2017-10-12T13:38:58.3931171-04:00
EventsListeners: 0
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

However, when i run this simple commands it just stops responding:

docker container run hello-world:nanoserver

Any help would be greatly appreciated.


(Tesdalld) #2

I disabled the windows firewall service and rebooted. Now i get the following:

docker container run hello-world:nanoserver

C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: container 89f8c49d505e74ac3b1472863
aca325a6b2dcaf5b9450467e945f38e28e93429 encountered an error during CreateContainer: failure in a Windows system call: The parameter is incorrect. (0x57) extra info: {“SystemType”:“Container”,“Name”:“89f8c49d505e74ac3b1472863aca325a6b2dcaf5
b9450467e945f38e28e93429”,“Owner”:“docker”,“VolumePath”:"\\?\Volume{81f777f0-af69-11e7-90f7-00155d6ab227}",“IgnoreFlushesDuringBoot”:true,“LayerFolderPath”:“C:\ProgramData\Docker\windowsfilter\89f8c49d505e74ac3b1472863aca325a6b2dcaf5
b9450467e945f38e28e93429”,“Layers”:[{“ID”:“52b293c0-5c90-5653-b19f-0981003cf186”,“Path”:“C:\ProgramData\Docker\window sfilter\d4f0e35c17b55cdedfe800b1a030e8c015b48435f272bb12727a1303a5d3f5b7”},{“ID”:“9d1b40a5-8305-5b24-bbb5-3a7b6df39309”
,“Path”:“C:\ProgramData\Docker\windowsfilter\7e5adf80e879d5237912857bc12138487cea99d75866b3d797d61b03a8cc34a6”},{“ID
”:“038d41f3-6cab-5f2f-b40f-6f28a6e0de35”,“Path”:“C:\ProgramData\Docker\windowsfilter\e560cd4ee8045700e1acd5bf6161a81
aebf71569f436fb66902694e713d90802”},{“ID”:“f4676adf-c2ef-5941-a40c-ff6401028806”,“Path”:“C:\ProgramData\Docker\window
sfilter\0163953e2e2c216a70d6cdfed2d65d87518bbddc23fcc592947e61f3e0503106”}],“HostName”:“89f8c49d505e”,“HvPartition”:fal
se,“EndpointList”:[“e01e5ec1-af54-4380-ba55-cd01f512170d”],“AllowUnqualifiedDNSQuery”:true}.


(Tesdalld) #3

I turned the firewall back on and now it is stuck at Docker container run hello-world:nanoserver The courser is just blinking on the next line.


(Iamamosh) #4

By any chance, do you have Docker for Windows (D4W) installed on the same machine? It is a product that lets developer run Linux and Windows container for test purpose on desktop OS like Windows 10. For production load, you can install Docker EE engine onto Windows Server 2016.

And if you buy support from Microsoft, they can help you troubleshoot with EE engine too. Maybe, this instruction will help.


(Tesdalld) #5

Yes, I installed docker for windows. I will remove it and add docker EE.


(Tesdalld) #6

I uninstalled docker for windows. I ran through the installation of EE. When I run the command docker container run hellow-world:nanoserver it just sits there…


(Tesdalld) #7

I blew away the VM and re-created a brand new 2016 VM. I ran

Install-Module DockerProvider -Force
Install-Package Docker -ProviderName DockerProvider -Force

I had to reboot twice and the service (docker) started.

I ran the test command and I got the following:

docker container run hello-world:nanoserver
Unable to find image 'hello-world:nanoserver' locally
nanoserver: Pulling from library/hello-world
bce2fbc256ea: Pull complete
b0b5e40cb939: Pull complete
87377cdc7dd1: Pull complete
7d840042f15f: Pull complete
Digest: sha256:09084a40d44e22bd468beb17ca48a85f7b23c1ee07e68e7ea1df6827e38205f7
Status: Downloaded newer image for hello-world:nanoserver

now it is just sitting at the blinking courser again.


(2545) #8

Hi , Am facing the same issue did you find the solution for the same…?