Docker Community Forums

Share and learn in the Docker community.

Unable to run Docker Container on an AWS Windows VM


(Shekharsh) #1

I have used AWS Windows 2016 instances to run Docker containers and Swarm. This was mostly done for my own learning.

For the last few days, I have tried to use Windows 2016 container base (Microsoft Windows Server 2016 Base with Containers - ami-05c2d010ff77e020c) to install Docker and pull the microsoft/nanoserver image. The image pull version seems to work perfectly fine but when I try to run a container from the same image in detached mode, the container starts and then exits. Has something changed with AWS or Windows 2016 in the last three weeks?


(Shekharsh) #2

I tried to use the following images to run nanoserver.

Microsoft Windows Server 1709 with Containers - ami-018cc6b82bb6dba5d

Microsoft Windows Server 1803 with Containers - ami-03572451e386b50dc

I got an error that says I cannot run these images with these Windows versions because those images are incompatible.


(Shekharsh) #3

I had used the wrong docker image. I need to remember to use the right tag to pull the image appropriate for the OS. I should have used microsoft/nanoserver:1709 or microsoft/nanoserver:1803.