Docker Community Forums

Share and learn in the Docker community.

Creating container for linux/arm64

I’m New to Docker and looking to created docker containers from splunk/splunk but experiencing the following issue:

docker: no matching manifest for linux/arm64/v8 in the manifest list entries. I have installed rosetta and i have changed the platform to linux/amd64 but doing this does not allow me to run the Emulator.

I’ve even opened a terminal and did a pull which also fails:

test quintinvo$ docker pull splunk/splunk
Using default tag: latest
latest: Pulling from splunk/splunk
no matching manifest for linux/arm64/v8 in the manifest list entries

This only tells me that there isn’t a container supporting arm64 therefore i wanted to take an existing container and build it again with the hopes of creating one under the Apple M1 silicone chipset. But i honestly have no idea where to start. Is it possible to take a linux/amd64 container and rebuild it into a linux/arm64 container.

No. You would have to rebuild all the libraries, executables so all of the binaries inside the container. You can use a compatible image and download the source code of the application and build that application to the new architecture.

Isn’t that for supporting Intel processors for apps on the host? If you are on Mac, Docker Desktop contains the emulator but not always work.

How did you do that?

Hi Rimelek

Thank you for your feedback. we have a git repository with a docker.composer.yml where i specified the architect for example:

  hf:
    platform: linux/amd64
    networks:
      splunknet:
        aliases:
          - hf
    image: ${SPLUNK_IMAGE:-splunk/splunk:latest}

Use code blocks, please (</> button). Otherwise people will have a hard time to understand your code without any indentation which is an important part of yaml. I edited your post to fix it.

Exactly what version of MacOS are you using and on what hardware?

I tried on MacOS Monterey, MacBook with the M1 CPU. I tried with Docker Compose and I also tried using the docker command. I tried docker pull and docker run too. All of them worked as I expected.

Hi Rimelek

Im on macOS Monterey, Version 12.0.1, MacBook Pro (13-inch, M1, 2020)
Chip Apple M1

Regards

My last idea. Open Docker Desktop, go to Settings, click on “Experimental Features”. Is the new virtualization framework enabled? I tried and it worked for me enabled and disabled but we have almost identical environment (mine is MacBook Air but everything else is the same) and I can’t reproduce your issue.

Hi Rimelek…

What are you getting back on your terminal when running the following command:

docker pull splunk/splunk:latest

I also did what you suggested, enabling “Experimental Features” and this did not work. I believe my only solution would be to create/build an image myself.

Probably an error message as I remember (I can’t try it now). I used docker pull --platform linux/amd64 splunk/splunk as you should.