Docker Community Forums

Share and learn in the Docker community.

Daemon: mkdir permission denied when starting container from docker cli and docker-compose

I’m having a problem with running amazon/dynamo-db local image on Debian GNU/Linux 9.13 (stretch). It appears to have something to do with permissions in the btrfs file system

When I run the local command

sudo docker run -p 8000:8000 amazon/dynamodb-local

Response

docker: Error response from daemon: mkdir /var/lib/docker/btrfs/subvolumes/01802b192b54827237ebcb1f70e68ed36d5723e4c2d2b77bb2a2d7159afeeffe-init/etc: permission denied.

Expected response - up until today it was running the container local host 8000. Previously had worked with a direct docker command and using docker compose

Attempted fixes

  1. Stopped and removed all containers
  2. Removed all volumes
  3. Removed and reinstated amazon/dynamodb-local image
  4. Removed and reinstalled docker-ce

Other behaviour

  1. Docker hello world works fine so the issue does not impact simple images

Any assistance would be greatly appreciated