Docker Community Forums

Share and learn in the Docker community.

Docker on Ubuntu 19.04 (locally) - docker run commad ends in permission denied

I have a virtual machine (locally) with ubuntu 19.04 (with gui) and have installed docker-ce.
The docker image hello-world runs!

Now i have another docker image, when i run this i get an error:

/usr/bin/python3: can’t open file '/sbin/my_init!: [Errno 13] permission denied

If i type

docker ps -a
i see the exited container.

On play-with-docker.com this exactly docker image works!

I feel like you think you expressed everything…

How (as in: the exact command!) did you start the failing container?

1 Like

I don’t think it’s important :blush: but

docker run -d -p 80:80 image-name

to see no output
or

docker run -it image-name bash

to go into the started container to the bash

docker logs container-name

shows the same permission denied.

PS: I know how to start/run a container.:wink:

I ment it litteraly, the EXACT command with all bells and whistles. People tend to abstract to what they think would be relavant and usualy hide the problem itself.

The only thing I can say to the generics you posted: it works for others!

2 Likes

And like i said it works on play-with-docker.com too!:wink:

The problem is either caused by the way you use docker or by docker (or its dependencies) itself.
Your responses clearly do not to provide any details to rule out either one of those.

All you have told us is: “There is something wrong somewhere”.

  • Is your intention to just complain: to blame docker. If it is dockers fault then you can move on.
  • Is it to get our attention? If so then you have it, but are about to loose it. So tell us what you did. Since the new regulation, we are no longer allowed to spy on you :slight_smile:, so you will have to tell us what you are doing and what happened.
  • Is your intention to get help? If so then tell us what you have tried, tell us what happened. Include the stuff that you think we know (e.g. you say image-name, but what is the image). Everything you say so far is so generic, it could be copied form the manual, and it works. The error must be in some variation from this.
1 Like

It’s crazy! :see_no_evil::hear_no_evil::speak_no_evil:
If i do the same on play-with-docker.com and on my own local vm machine and one work, the other not, so i don’t think i have to tell all commands i’ve typed because - like i said - on one platform it works!:wink:

I will test another time…:roll_eyes:

It seems to me that you are not interested in finding a solution; That you just want to blame someone. Is this correct?