Docker Community Forums

Share and learn in the Docker community.

Debian 10 - Docker installation (Package 'gnupg2' has no installation candidate)

Hello everyone,

I’ve just started my first Docker installation on Debian 10 and while I run the following command from the installation guide:
$ sudo apt install apt-transport-https ca-certificates curl gnupg2 software-properties-common
thata

I get:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘apt’ instead of ‘apt-transport-https’
Package gnupg2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
gpgv

E: Package ‘gnupg2’ has no installation candidate
E: Unable to locate package software-properties-common

I cannot find a way to fix that.

Any clue?

Thank you in advance.
Luca.

which apt repos have you got?

Hello,

have you tried to replace gnupg2 with gpgv as shown ?

or simply apt update before

1 Like